This service will be undergoing non-disruptive maintenance at 07:20 UTC, 2018-12-14. It is expected to last approximately 30 minutes
Bug 228583 - frontpage.cgi lists the same bugs multiple times in "Issues with Flags You Have Requested"
Summary: frontpage.cgi lists the same bugs multiple times in "Issues with Flags You Ha...
Status: CLOSED NEXTRELEASE
Alias: None
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
(Show other bugs)
Version: 3.2
Hardware: All Linux
medium
medium vote
Target Milestone: ---
Assignee: Noura El hawary
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-13 21:15 UTC by Ulrich Drepper
Modified: 2013-06-24 04:17 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-03 10:49:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
v1 for adding code to forntpage.cgi to remove duplicate entries (864 bytes, patch)
2008-12-02 04:01 UTC, Noura El hawary
dkl: review+
Details | Diff

Description Ulrich Drepper 2007-02-13 21:15:52 UTC
Description of problem:
See $summary and the screenshot

https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=148017

(I'm not going to attach the same screenshot twice).

Version-Release number of selected component (if applicable):
2.18

How reproducible:
always

Steps to Reproduce:
1.log on as me
2.
3.
  
Actual results:
see screenshot

Expected results:
no bug listed more than once

Additional info:

Comment 1 ferg2k 2007-03-26 08:58:36 UTC
consider amending your query logic to
   SELECT DISTINCT FROM
if you're using newer mysql

or
   GROUP BY bugs.bug_id
if you're using an older version.

Comment 2 David Lawrence 2008-09-16 16:55:09 UTC
Red Hat Bugzilla is now using version 3.2 of the Bugzilla codebase and therefore this bug will need to be re-verified against the new release. With the updated code this bug may no longer be relevant or may have been fixed in the new code.
Updating bug version to 3.2.

Comment 3 Ulrich Drepper 2008-09-16 20:16:58 UTC
The problem is still present.  I can attach a new screenshot, if necessary, but the problem is the same.  In the "Open Issues with FLAGS You Have Requested" list one of the bugs is listed twice.

Comment 4 Noura El hawary 2008-12-02 04:01:15 UTC
Created attachment 325330 [details]
v1 for adding code to forntpage.cgi to remove duplicate entries

I have verified this problem, and found the fix by adding GROUP BY to the SQL query to group results by bug ids and that prevented duplicate bug entries.

Noura

Comment 5 David Lawrence 2008-12-02 17:26:19 UTC
Comment on attachment 325330 [details]
v1 for adding code to forntpage.cgi to remove duplicate entries

Looks fine Noura.

Comment 6 Noura El hawary 2008-12-03 10:49:02 UTC
Thanks for the review Dave, patch has been committed to cvs, should go live on Thursday.

Noura


Note You need to log in before you can comment on or make changes to this bug.