Bug 22862 - No versioning on librpm* ?
No versioning on librpm* ?
Status: CLOSED DUPLICATE of bug 20176
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-26 20:56 EST by Bill Crawford
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-27 08:56:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bill Crawford 2000-12-26 20:56:36 EST
I have logged a bug also under gnorpm, as it now fails to run due to a
missing function in the latest librpm.so. I think that either librpm should
have accurate versioning or their should be a higher degree of backwards
compatibility maintained across versions of librpm.
Comment 1 Jeff Johnson 2000-12-27 08:55:58 EST
Yup. There's a soname change pending in rpm, and I'm just now looking at the API
creep with
tools lioke gnorpm and kpackage. FWIW, both gnorpm and kpackage are what need to
change.
Comment 2 Jeff Johnson 2001-01-08 10:34:15 EST

*** This bug has been marked as a duplicate of 20176 ***

Note You need to log in before you can comment on or make changes to this bug.