This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 228672 - yum-downloadonly - Not allow to update package with yum
yum-downloadonly - Not allow to update package with yum
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-14 06:45 EST by Amanpreet Singh Brar Alamwalia
Modified: 2014-01-21 17:57 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-21 17:07:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Amanpreet Singh Brar Alamwalia 2007-02-14 06:45:26 EST
Description of problem:
after removing only, update possible, with this showing following error
---------

Is this ok [y/N]: y
Downloading Packages:
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 172, in main
    base.doTransaction()
  File "/usr/share/yum-cli/cli.py", line 301, in doTransaction
    problems = self.downloadPkgs(downloadpkgs) 
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 717, in downloadPkgs
    self.plugins.run('postdownload', pkglist=pkglist, errors=errors)
  File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 153, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/downloadonly.py", line 31, in postdownload_hook
    if opts.dlonly:
AttributeError: 'NoneType' object has no attribute 'dlonly
----------


Version-Release number of selected component (if applicable):

yum-downloadonly-1.0.2-2.fc7

How reproducible:
Evertime with this plugin

Steps to Reproduce:
1. update with latest yum
2. try to install some page with yum
3.
  
Actual results:
show error as above

Expected results:
should work normal

Additional info:
Comment 1 Tim Lauridsen 2007-02-19 06:53:05 EST
This is caused by a bug in yum 3.1.1, The command line options are not passed to
the plugins.

It is fixed upstream in yum CVS head.
http://devel.linux.duke.edu/cgi-bin/viewcvs.cgi/yum/cli.py?r1=1.255&r2=1.256

Jeremy:
Maybe, you could add the upstream fix, as a patch to yum-3.1.1 in rawhide,
because all plugins there added command line options (skip-broken etc), will not
work with the current 3.1.1 in rawhide.


Comment 2 Jeremy Katz 2007-02-21 17:07:40 EST
3.1.2 will be in rawhide as of tomorrow

Note You need to log in before you can comment on or make changes to this bug.