Bug 228681 - php-5.0.4-10.5 suffers from PHP-bug 31054
Summary: php-5.0.4-10.5 suffers from PHP-bug 31054
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: php   
(Show other bugs)
Version: 4
Hardware: All All
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact: David Lawrence
URL: http://bugs.php.net/bug.php?id=31054
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-14 13:24 UTC by Wouter de Jong
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-10 19:30:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
PHP Bug Tracker 31054 None None None Never

Description Wouter de Jong 2007-02-14 13:24:37 UTC
Description of problem:
php-5.0.4-10.5 (current FC4) suffers from PHP Bug 31054 
(http://bugs.php.net/bug.php?id=31054) :

include_path is not traversed fully when open_basedir nonmatching

Version-Release number of selected component (if applicable):
php-5.0.4-10.5

How reproducible:
Follow the steps in the bugreport.

The problem is that we have several FC4 machines running SWSoft's Plesk 
(Control Panel - www.swsoft.com), and cannot simply update it to FC5 due to 
customers relaying on specific versions.

We can ofcourse rebuild the rpm with the fixes, but it would be neet if the 
rest of the world could use them to. I know FC4 is legacy, but I hope this 
could be taken into account since I know there are a lot of servers that are 
running these versions.

Comment 1 Matthew Miller 2007-04-10 19:30:01 UTC
We can't fix this. There's not even an infrastructure for doing so anymore.
Servers running FC4 at this point is insane. If your customers need longer
stability, use CentOS or pay for RHEL. Fedora *must* be updated at least every
other release.


Note You need to log in before you can comment on or make changes to this bug.