Bug 228791 - Suspend/resume not working
Suspend/resume not working
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-14 19:46 EST by Austin Foxley
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-04 21:46:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of lspci -vv (11.71 KB, application/octet-stream)
2007-02-14 19:46 EST, Austin Foxley
no flags Details

  None (edit)
Description Austin Foxley 2007-02-14 19:46:58 EST
Description of problem:
On a relatively new Toshiba Satellite P105 laptop, suspend to ram is non
functional. It goes down just fine, but on resume the system hangs (not able to
ssh in, so it's not just the monitor not coming back). Can't figure out how to
get a dump of anything, but attached is lspci (laptop is intel ich7 chipset)

Google turned up that it might be related to the ata_piix driver (which this
system uses)


Version-Release number of selected component (if applicable):
kernel-2.6.20-1.2925.fc7

How reproducible:
run pm-suspend

Actual results:
system hangs when coming back

Expected results:
system should resume to previous state
Comment 1 Austin Foxley 2007-02-14 19:46:59 EST
Created attachment 148094 [details]
output of lspci -vv
Comment 2 Daryll 2007-02-17 02:16:39 EST
I've got the same sort of problem on a very new Core 2 Duo system from HP using
FC6. The system partially shutdowns down and doesn't wake up. It requires a hard
shutdown to restart it.

But a couple more pieces of information. Hibernate has never worked. It appears
to fail in a very similar way, but I don't have anything to compare against.

Suspend worked in kernel 2.6.18-1.2869.fc6. I've run every release kernel since
then, and they've all failed to resume. 

When the system suspends, it doesn't seem to be completing the process. Under
the working kernel the blue power led light flashes and the machine runs very
cool when the suspend completes. Under later kernels the blue power led stays on
and the machine runs warm using up the battery.

On my current 2.6.19-1.2911.fc6 kernel. I get messages saying:
Feb 16 19:33:19 ninja gnome-power-manager: (daryll) Suspending computer because
the lid has been closed on ac power
Feb 16 19:33:19 ninja NetworkManager: <information>	Going to sleep. 
Feb 16 19:33:19 ninja avahi-daemon[2870]: Interface eth1.IPv6 no longer relevant
for mDNS.
Feb 16 19:33:19 ninja avahi-daemon[2870]: Leaving mDNS multicast group on
interface eth1.IPv6 with address fe80::218:deff:fe16:8c90.
Feb 16 19:33:19 ninja avahi-daemon[2870]: Interface eth1.IPv4 no longer relevant
for mDNS.
Feb 16 19:33:19 ninja avahi-daemon[2870]: Leaving mDNS multicast group on
interface eth1.IPv4 with address 192.168.123.136.
Feb 16 19:33:19 ninja avahi-daemon[2870]: Withdrawing address record for
fe80::218:deff:fe16:8c90 on eth1.
Feb 16 19:33:19 ninja avahi-daemon[2870]: Withdrawing address record for
192.168.123.136 on eth1.
Feb 16 19:33:19 ninja dhclient: DHCPRELEASE on eth1 to 192.168.123.254 port 67
Feb 16 19:33:19 ninja dhclient: send_packet: Network is unreachable
Feb 16 19:33:19 ninja dhclient: send_packet: please consult README file
regarding broadcast address.
Feb 16 19:33:22 ninja kernel: ACPI: PCI interrupt for device 0000:02:00.0 disabled
nFeb 16 19:33:23 ninja NetworkManager: <information>	Deactivating device eth1. 
Feb 16 19:33:23 ninja kernel: ieee80211: 802.11 data/management/control stack,
1.2.16
Feb 16 19:33:23 ninja kernel: ieee80211: Copyright (C) 2004-2005 Intel
Corporation <jketreno@linux.intel.com>
Feb 16 19:33:23 ninja kernel: ipw3945: Intel(R) PRO/Wireless 3945 Network
Connection driver for Linux, 1.2.0d
Feb 16 19:33:23 ninja kernel: ipw3945: Copyright(c) 2003-2006 Intel Corporation
Feb 16 19:33:23 ninja kernel: ACPI: PCI Interrupt 0000:02:00.0[A] -> GSI 16
(level, low) -> IRQ 16
Feb 16 19:33:23 ninja kernel: ipw3945: Detected Intel PRO/Wireless 3945ABG
Network Connection
Feb 16 19:33:23 ninja NetworkManager: <WARNING>	
nm_device_802_11_wireless_get_mode (): error getting card mode on eth1: No such
device 
Feb 16 19:33:23 ninja hidd[2439]: Exit
Feb 16 19:33:23 ninja sdpd[2373]: terminating...   
Feb 16 19:33:24 ninja hcid[2366]: Unregister path:/org/bluez/hci0
Feb 16 19:33:24 ninja hcid[2366]: Unregister path:/org/bluez
Feb 16 19:33:24 ninja hcid[2366]: Exit
Feb 16 19:33:24 ninja ntpd[2608]: ntpd exiting on signal 15
Feb 16 19:33:25 ninja kernel: Disabling non-boot CPUs ...
...At this point the system is hung

Under the 2.6.18-1.2869 kernel the messages prior to shutdown are:
Feb  3 22:19:19 ninja gnome-power-manager: (daryll) Suspending computer because
the lid has been closed on ac power
Feb  3 22:19:19 ninja NetworkManager: <information>	Going to sleep. 
Feb  3 22:19:19 ninja dhclient: receive_packet failed on eth1: Network is down
Feb  3 22:19:19 ninja avahi-daemon[2656]: Interface eth1.IPv6 no longer relevant
for mDNS.
Feb  3 22:19:19 ninja avahi-daemon[2656]: Leaving mDNS multicast group on
interface eth1.IPv6 with address fe80::218:deff:fe16:8c90.
Feb  3 22:19:19 ninja avahi-daemon[2656]: Interface eth1.IPv4 no longer relevant
for mDNS.
Feb  3 22:19:19 ninja avahi-daemon[2656]: Leaving mDNS multicast group on
interface eth1.IPv4 with address 192.168.123.136.
Feb  3 22:19:19 ninja avahi-daemon[2656]: Withdrawing address record for
fe80::218:deff:fe16:8c90 on eth1.
Feb  3 22:19:19 ninja avahi-daemon[2656]: Withdrawing address record for
192.168.123.136 on eth1.
Feb  3 22:19:19 ninja dhclient: DHCPRELEASE on eth1 to 192.168.123.254 port 67
Feb  3 22:19:19 ninja dhclient: send_packet: Network is unreachable
Feb  3 22:19:19 ninja dhclient: send_packet: please consult README file
regarding broadcast address.
Feb  3 22:19:23 ninja hidd[2353]: Exit
Feb  3 22:19:24 ninja sdpd[2298]: terminating...   
Feb  3 22:19:24 ninja hcid[2294]: Unregister path:/org/bluez/hci0
Feb  3 22:19:24 ninja hcid[2294]: Unregister path:/org/bluez
Feb  3 22:19:24 ninja hcid[2294]: Exit
Feb  3 22:19:24 ninja ntpd[2444]: ntpd exiting on signal 15
Feb  3 22:19:26 ninja kernel: Disabling non-boot CPUs ...
Feb  3 22:19:26 ninja kernel: Breaking affinity for irq 9
Feb  3 22:19:26 ninja kernel: Breaking affinity for irq 12
Feb  3 22:19:26 ninja kernel: Breaking affinity for irq 14
Feb  3 22:19:26 ninja kernel: Breaking affinity for irq 58
Feb  3 22:19:26 ninja kernel: Breaking affinity for irq 74
Feb  3 22:19:26 ninja kernel: Breaking affinity for irq 185
Feb  3 22:19:26 ninja kernel: CPU 1 is now offline
Feb  3 22:19:26 ninja kernel: SMP alternatives: switching to UP code
... at this point the system has shut down but wakes up with a key press.

I hope this helps. Being able to suspend was great. I really miss that feature,
and have continued to use the old kernel because of that.
Comment 3 Chuck Ebbert 2007-02-17 13:17:14 EST
Try stopping the cpuspeed service before suspending.
Comment 4 Daryll 2007-02-18 20:12:33 EST
Stopping cpuspeed does allow suspend to work correctly on the 2.6.19 kernel. 

Hibernate still hangs (as it always has). It reports the SMP alternative:
switching to UP code. But the power is still on in the system. and requires a
hard reboot to continue.

Thanks for the help on the suspend. It would be nice if both worked, but suspend
is the more important to me.

Comment 5 Austin Foxley 2007-02-19 17:08:04 EST
stopping cpuspeed does not help on any of the following kernels:
2.6.20-1.2922.fc7
2.6.20-1.2925.fc7
2.6.20-1.2932.fc7

Not sure how i can go about getting more information (dmesg at time of crash?)...
Comment 6 Richard Steck 2007-02-23 14:48:15 EST
This was an annoying bug that I couldn't fix for a long time on FC5 and FC6, 
but stopping cpuspeed on  2.6.19-1.2911.fc6.i86  did the job.  

I hope the fix is incorporated in future versions of the kernel.

Thanks to everyone.
Comment 7 Richard Hughes 2007-05-24 06:36:19 EDT
If suspend is not working, can you refer to
http://people.freedesktop.org/~hughsient/quirk/ and close this bug if you get
things working. Thanks!
Comment 8 Austin Foxley 2007-05-24 08:45:46 EDT
I've been watching your progress on that tool, and I really like it. However
I've been unable to get it working yet.

I've tried all the quirks, as well as all the suggested boot options. Yesterday
I tried the RTC hash trick, and I got "hash matches device tty23", but wasn't
sure what to do next (how do you get rid of your tty's?)

The only way for me to get sound on this laptop is to replace my DSDT so i'm
going to do that later today, and maybe that will help suspend?

Any other thoughts? 
Comment 9 Richard Hughes 2007-05-24 09:21:09 EDT
(In reply to comment #8)
> I tried the RTC hash trick, and I got "hash matches device tty23", but wasn't
> sure what to do next (how do you get rid of your tty's?)

tty23 could be being used in kernel or out of kernel. What is the output of:

lsof /dev/tty23

Is it always tty23? Can you retry this a few times to check please. Thanks.

> The only way for me to get sound on this laptop is to replace my DSDT so i'm
> going to do that later today, and maybe that will help suspend?

Depends on the ACPI interaction. I doubt you'll make much difference unless
you'll a l33t DSL hacker :-)

Richard.
Comment 10 Austin Foxley 2007-07-19 09:21:27 EDT
Sorry this kind of got dropped by me.

I tried the RTC hash trick a few more times, and was actually unable to get it
to tell me anything (except "hash matches drivers/base/power/resume.c:26" once,
with no other entry)

This was on a fairly old kernel (2 months ago?), so I'll update and try again if
you think it will make any difference. The laptop is actually my friends.
Comment 11 Austin Foxley 2007-09-04 21:46:26 EDT
Suspend to RAM is now working on this laptop. This is on:
kernel-2.6.23-0.161.rc5.fc8
hal-0.5.10-0.git20070731.fc8.2

I needed to add --quirk-vbe-post to pm-suspend to get X to come back, and I've
already submitted a patch to hal-info to fix this.

Note You need to log in before you can comment on or make changes to this bug.