Bug 228818 - No longer works on devices which doesn't support SETTRIGGER
No longer works on devices which doesn't support SETTRIGGER
Product: Fedora
Classification: Fedora
Component: audacity (Show other bugs)
All Linux
medium Severity high
: ---
: ---
Assigned To: Gérard Milmeister
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-02-15 05:23 EST by Pierre Ossman
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-02-15 16:16:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Pierre Ossman 2007-02-15 05:23:53 EST
It seems that though the audacity spec file seems to indicate that PortAudio v18
should be used by default, it is in fact v19 that is used in the currently built
package. And because of bugs in v19, devices which do not support SETTRIGGER do
not work.
Comment 1 Gérard Milmeister 2007-02-15 13:43:55 EST
I made audacity compile against portaudio v18 from Extras. Could there be any
negative effects from using v18 instead of v19?
Comment 2 Pierre Ossman 2007-02-15 14:45:58 EST
No idea. I'm more of a casual user. :)
Comment 3 Gérard Milmeister 2007-02-15 16:16:52 EST
Well, I decided to leave portaudio v19 in. However, now the alsa devices are
properly supported. I also compiled with jack support. 
Comment 4 Michael Schwendt 2007-02-15 17:19:00 EST
This needs "BuildRequires: alsa-lib-devel".
Comment 5 Gérard Milmeister 2007-02-15 17:51:00 EST

Note You need to log in before you can comment on or make changes to this bug.