Bug 228860 - init script does not support condrestart
init script does not support condrestart
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: autofs (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ian Kent
Brock Organ
:
Depends On:
Blocks: 231956
  Show dependency treegraph
 
Reported: 2007-02-15 11:21 EST by Orion Poplawski
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 5.0.1-0.rc3.23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-22 13:29:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2007-02-15 11:21:54 EST
Description of problem:

postuninstall scriptlet (using /bin/sh):
if [ $1 -ge 1 ] ; then
        /sbin/service autofs condrestart > /dev/null 2>&1 || :
fi

#  /sbin/service autofs condrestart
Usage: /etc/init.d/autofs {start|stop|status|restart|reload}

Version-Release number of selected component (if applicable):
autofs-5.0.1-0.rc3.16
Comment 1 Ian Kent 2007-02-15 21:10:58 EST
(In reply to comment #0)
> Description of problem:
> 
> postuninstall scriptlet (using /bin/sh):
> if [ $1 -ge 1 ] ; then
>         /sbin/service autofs condrestart > /dev/null 2>&1 || :
> fi
> 
> #  /sbin/service autofs condrestart
> Usage: /etc/init.d/autofs {start|stop|status|restart|reload}
> 
> Version-Release number of selected component (if applicable):
> autofs-5.0.1-0.rc3.16

Oops. Will fix.

Ian
Comment 2 Orion Poplawski 2007-02-22 13:29:59 EST
Confirmed fixed in 5.0.1-0.rc3.23
Comment 3 Stephen Martin 2007-03-04 08:49:00 EST
autofs-5.0.1-0.rc3.23 seems to hang my automount connections. I went back to
autofs-5.0.1-0.rc3.21 and everything is fine. I can't see any other symptoms
such as log messages.

Note You need to log in before you can comment on or make changes to this bug.