Bug 228968 - sa-learn perl error since update
sa-learn perl error since update
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: spamassassin (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Warren Togami
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-16 04:58 EST by David Jansen
Modified: 2007-11-30 17:11 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-21 08:55:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Jansen 2007-02-16 04:58:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8.0.9) Gecko/20070209 Fedora/1.5.0.9-3.fc6 Firefox/1.5.0.9 pango-text

Description of problem:
Since I installed the spamassassin update (3.1.8-1) this morning, sa-learn gives errors like this:

archive-iterator: invalid (undef) format in target list, 2 at /usr/lib/perl5/vendor_perl/5.8.8/Mail/SpamAssassin/ArchiveIterator.pm line 724, <STDIN> line 1.
Learned tokens from 1 message(s) (1 message(s) examined)

This is sa-learn invoked manually (in mutt: | sa-learn --spam); spamassassin inside evolution doesn't seem to give errors

Version-Release number of selected component (if applicable):
spamassassin-3.1.8-1.fc6.i386

How reproducible:
Always


Steps to Reproduce:
1. open a mailbox in mutt
2. select spam message
3. type '| sa-learn --spam' (actually, I have this bound to a key of course)


Actual Results:
archive-iterator: invalid (undef) format in target list, 2 at /usr/lib/perl5/vendor_perl/5.8.8/Mail/SpamAssassin/ArchiveIterator.pm line 724, <STDIN> line 1.
Learned tokens from 1 message(s) (1 message(s) examined)


Expected Results:
Until yesterday, only the message 
Learned tokens from 1 message(s) (1 message(s) examined)
was shown

Additional info:
Comment 1 Warren Togami 2007-02-16 11:26:45 EST
http://issues.apache.org/SpamAssassin/show_bug.cgi?id=5336
Could you please test the upstream patch for this issue?
Comment 2 David Jansen 2007-02-21 08:17:40 EST
Upstream patch seems to work fine, thanks!

Note You need to log in before you can comment on or make changes to this bug.