This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 228995 - qt4-doc: examples/qmake/ not included
qt4-doc: examples/qmake/ not included
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: qt4 (Show other bugs)
6
All Linux
medium Severity low
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-16 07:53 EST by Laurent Rineau
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-03 08:29:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Laurent Rineau 2007-02-16 07:53:14 EST
Description of problem:
Examples from examples/qmake/ (in qt4 source tarball) are cited 
in %{_datadir}/doc/qt4/html/qmake-tutorial.html 
and %{_datadir}/doc/qt4/html/qmake-precompiledheaders.html 

They should then be included in qt4-doc as well.

Version-Release number of selected component (if applicable):
qt4-doc-4.2.2-1.fc6


Steps to Reproduce:
$ grep -rl examples/qmake /usr/lib*/qt4/doc/html/
/usr/lib/qt4/doc/html/qmake-tutorial.html
/usr/lib/qt4/doc/html/qmake-precompiledheaders.html
$ ls /usr/lib*/qt4/examples/qmake
zsh: no matches found: /usr/lib*/qt4/examples/qmake


Expected results:
examples/qmake/, from the source tarball, should be installed 
at /usr/lib*/qt4/examples/qmake/.

Additional info: 
  - examples/qmake/qmake.pro does not exists.
  - examples/qmake/*/*.pro do not have any install variables (INSTALLS, 
target.path...).
Comment 1 Rex Dieter 2007-02-16 08:10:15 EST
Looks like a bug in 'make install', all the other examples from the tarball get
installed, I wonder why/how examples/qmake is skipped.
Comment 2 Laurent Rineau 2007-04-03 05:47:42 EDT
This is still an issue in the upcoming qt4-4.3.0 package. I have installed 
qt4-4.3.0-0.2.beta.fc6 on my machine (from kde-redhat, I guess).
Comment 3 Rex Dieter 2007-07-03 07:55:29 EDT
Interesting in informing upstream?
Comment 4 Laurent Rineau 2007-07-03 08:22:52 EDT
I am not subscribed to any Qt mailing list. I thought you were about to inform 
the upstream of that issue. You want me to do it?
Comment 5 Rex Dieter 2007-07-03 08:29:30 EDT
> You want me to do it?
preferably.  

I mean I could do it, eventually, but my plate's pretty full, so "eventually"
may end up being many weeks/months before I get round-tuit.
Comment 6 Laurent Rineau 2007-07-03 10:20:59 EDT
I have reported that bug to the Trolltech task tracker. Let us wait and see if 
something happens.
Comment 7 Laurent Rineau 2007-07-09 05:56:56 EDT
The bug report has been accepted: 
http://trolltech.com/developer/task-tracker/index_html?id=170148&method=entry

Quote from a mail I received, that explains the problem:
"Thank you for the report.

Indeed, the qmake example should probably be copied over to the
installation directory with the other examples. One problem, though, is
that the tutorial example does not contain a .pro file (creating it is
part of the tutorial), so qmake cannot retrieve information about it
(which is used to install the other examples). This is thus a special
case that will need special handling.

I will pass this information on to the documentation or development
teams, but I cannot guarantee that this will be changed any time soon,
or if at all."

Note You need to log in before you can comment on or make changes to this bug.