Bug 229001 - Highlighted items in programs do not show checked
Highlighted items in programs do not show checked
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-themes (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
https://www.redhat.com/archives/fedor...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-16 08:45 EST by Jim Cornette
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-21 18:28:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim Cornette 2007-02-16 08:45:02 EST
Description of problem:
When using system-config-services and highlighting services, it is hard to
determine if the program is checked or not. The highlighted item shows an empty box.
Moving onto another item reveals that the previously item is indeed checked.

Version-Release number of selected component (if applicable):
gtk2-2.10.9-4.fc7
system-config-services-0.9.6-1.fc7

How reproducible:


Steps to Reproduce:
1. Launch s-c-services from menu
2. Enter password for root
3. Highlight service interested in starting, stopping
  
Actual results:

The item after highlighting does not appear to be checked.

Expected results:

The item to reflect the actual state of item. (checked or not checked)

Additional info:

This problem effects several programs and was discussed in the below thread.

https://www.redhat.com/archives/fedora-test-list/2007-February/msg00462.html
Comment 1 Scott Talbot 2007-02-16 10:05:38 EST
As a participant in the thread, I would like to add that this has affected me in
that s-c-security cannot change the status of the firewall. When I disable the
firewall and restart s-c-security it shows as enabled.

Also Pup is affected, in that it acts similarly to the way Jim describes
s-c-services, except that the only item in the list that is unchecked is the
highlighted item.  Selecting another package will check the current item and
uncheck the newly highlighted one.

Additionally (though I am not 100% certain this is the same bug though it seems
likely) yum (and pup) act strangely in that yum, (and updatesd) will not show me
any new packages until I 'yum clean metadata'

and (finally) after receiving root permissions via pam I do not get the badge
icon to show me that I have permissions and so I am constantly re-entering root
password even if I run 2 programs at once (usually there is a time that the
permissions expire). this may be a very big clue that the entire problem is that
 I lose root privileges immediately after program execution.  maybe this is a
red herring though.

IOT prove SELinux was not at fault I rebooted with selinux = 0 in the options
line and the problem persists
Comment 2 Scott Talbot 2007-02-16 10:13:10 EST
Update: apparently Pup is working today, at least the package de-selection
portion of the problem (no idea why though!).  still requires the 'yum clean
metadat before all packages are listed.
Comment 3 Matthias Clasen 2007-02-16 14:18:48 EST
theme problem
Comment 4 Jim Cornette 2007-02-16 22:40:21 EST
After entering the theme selector I found that a custom theme was selected with
no reference to what the theme was. After changing to CRUX and testing
s-c-services, the highlighted items work as expected.

Was a theme eliminated and the theme manager just picked custom or is there a
bug related to custom themes being set as default?
Comment 5 Scott Talbot 2007-02-17 12:57:00 EST
I also found that the default theme was a modified Clearlooks.  The only
difference I saw was that the modified theme used  a different icon package and
my system still acts strangely with the theme changed to the Clearlooks
(unmodified).

Today Pup would again not show multiple unchecked packages, but when I selected
to apply updates, suddenly the two packages which needed to be eliminated were.
S-c-security still does not act properly though I am able to get around the
problem by having the IPtables daemon stopped (I used chkconfig rather than
s-c-services
Comment 6 Jim Cornette 2007-02-21 17:41:28 EST
Updating bug report because of a thread on the test list. Apparently the
checkbox problem is most effected by the clearlooks theme.

https://www.redhat.com/archives/fedora-test-list/2007-February/msg00545.html
Comment 7 Matthias Clasen 2007-02-21 18:28:18 EST
Fixed in gtk-engines-2.9.3-2.fc7

Note You need to log in before you can comment on or make changes to this bug.