Bug 229042 - bin2iso: source file missing from -debuginfo
Summary: bin2iso: source file missing from -debuginfo
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: bin2iso   
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Hans de Goede
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-16 18:04 UTC by Ville Skyttä
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-19 14:06:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ville Skyttä 2007-02-16 18:04:34 UTC
http://www.redhat.com/archives/fedora-maintainers/2007-January/msg00339.html

bin2iso is caught by the optflag/debuginfo checker, because the (one and only) C
source file is missing from the debuginfo.  I don't see anything wrong in the
package, and a local rebuild of it on FC6 does make the source file end up in
-debuginfo.  So perhaps a simple rebuild is all it takes to fix it.

Comment 1 Hans de Goede 2007-02-19 14:06:45 UTC
Got IT!

The sources for this contain of a single C file which is SOURCE0, it got
compiled like this:
gcc -o bin2iso $RPM_OPT_FLAGS %{SOURCE0}

By first copying it to our working dir in %prep and then feeding the installed
file to gcc, the C-file shows up in the -debuginfo under mock too.

Closing.



Note You need to log in before you can comment on or make changes to this bug.