Bug 229103 - Yumex error (please change summary properly!!)
Yumex error (please change summary properly!!)
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-16 23:11 EST by Alexandre Laquerre
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-12 02:59:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Laquerre 2007-02-16 23:11:59 EST
Spec URL: <spec info here>
SRPM URL: <srpm info here>
Description: <Yumex Problem>

Hi, i wish i understood what i did wrong but everytime i start my yumex this 
information popups when i start the yumex and well i am still pretty new to this so im clueless to this problem.

Component: yumex
Version: 1.2.2
Summary: TB4426d5a1 ConfigParser.py:490:_read:ParsingError: File contains parsing errors: /etc/yum.repos.d/livna.repo
	[line 48]: 'x\n'

Traceback (most recent call last):
  File "/usr/share/yumex/yumexmain.py", line 1108, in ?
    mainApp = YumexMainApplication()
  File "/usr/share/yumex/yumexmain.py", line 506, in __init__
    self.repo = Repository()
  File "/usr/lib/python2.4/site-packages/yumex/yumexUtils.py", line 1265, in __init__
    self.update()
  File "/usr/lib/python2.4/site-packages/yumex/yumexUtils.py", line 1348, in update
    self.build_section_dict()
  File "/usr/lib/python2.4/site-packages/yumex/yumexUtils.py", line 1324, in build_section_dict
    tcfg.read( r )
  File "/usr/lib/python2.4/ConfigParser.py", line 267, in read
    self._read(fp, filename)
  File "/usr/lib/python2.4/ConfigParser.py", line 490, in _read
    raise e
ParsingError: File contains parsing errors: /etc/yum.repos.d/livna.repo
	[line 48]: 'x\n'

Local variables in innermost frame:
sectname: livna-source
cursect: {'name': 'Livna for Fedora Core $releasever - $basearch - Source', 'failovermethod': 'priority', 'gpgkey': 'file:///etc/pki/rpm-gpg/RPM-GPG-KEY-livna', 'enabled': '0', 'baseurl': '\nhttp://rpm.livna.org/fedora/$releasever/SRPMS/\nhttp://livna.cat.pdx.edu/fedora/$releasever/SRPMS/\nhttp://wftp.tu-chemnitz.de/pub/linux/livna/fedora/$releasever/SRPMS/\nhttp://ftp-stud.fht-esslingen.de/pub/Mirrors/rpm.livna.org/fedora/$releasever/SRPMS/\nhttp://mirror.atrpms.net/livna/fedora/$releasever/SRPMS/\nftp://mirrors.tummy.com/pub/rpm.livna.org/fedora/$releasever/SRPMS/', 'gpgcheck': '1', '__name__': 'livna-source'}
e: File contains parsing errors: /etc/yum.repos.d/livna.repo
	[line 48]: 'x\n'
fpname: /etc/yum.repos.d/livna.repo
vi: =
mo: None
value: ftp://mirrors.tummy.com/pub/rpm.livna.org/fedora/$releasever/SRPMS/
optname: gpgcheck
fp: <open file '/etc/yum.repos.d/livna.repo', mode 'r' at 0x9e1f458>
lineno: 49
line: 
self: <ConfigParser.ConfigParser instance at 0x9e27fec>
optval: 1
Comment 1 Tim Lauridsen 2007-02-17 02:02:35 EST
This error occours because there is a syntax error in /etc/yum.repos.d/livna.repo

Try to edit the file as root, if you can find the error then attach the file.

Comment 2 Tim Lauridsen 2007-03-21 09:33:40 EDT
Does it works now

Note You need to log in before you can comment on or make changes to this bug.