Bug 229146 - Firefox causes X to uses 50%+ CPU while waiting for page to load
Firefox causes X to uses 50%+ CPU while waiting for page to load
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-18 11:38 EST by Jon Burgess
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-08 11:51:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 372306 None None None Never

  None (edit)
Description Jon Burgess 2007-02-18 11:38:51 EST
Description of problem:
I've noticed that when firefox waits for a page to load the X server often takes
50%+ CPU. After trying a lot of combinations I think i've finally narrowed this
down to a problem with the tabbed window support.

Version-Release number of selected component (if applicable):
firefox-1.5.0.9-3.fc6.x86_64.rpm
also occurs with mozilla.org ff-2.0.0.1 i686 linux download

How reproducible:
Every time i'm waiting for a page to load with 2+ tabs open.

Steps to Reproduce:
1. Launch firefox -ProfileManager
2. create new profile with default options and launch.
3. try accessing a page which does not exist. For me http://10.0.0.1 is a good
one. This causes the browser to try loading the page for ~30 seconds until timeout.
4. While firefox is still trying to load the page, open an xterm run top. Look
at X cpu usage. 
5. After a few seconds of activity X will show ~1% CPU usage (i.e. everything
looks normal now).
6. Stop page load in firefox.
7. Go into preferences->tabs. Enable the "show tabs even when only one window
open" option so that the tab bar appears.
8. Try going to http://10.0.0.1 again.
9. Watch X CPU usage. For me X jumps to 50%+ and stays there for the 30+ seconds
that firefox tries to load the page
  
Actual results:
Having the tab bar open seems to cause firefox to hammer the X server while
loading new pages. At a guess, it could be the updates to do the nice
'Loading...' animation of the tabbed window title bar which cause the problem.

Expected results:
This is running FF on an AMD64 3000 so I don't expect the X server to need 50%+
CPU in order to tell me that FF is waiting for a page to load.

Additional info:
I'm using an NVidia FX5200 with the open source 'nv' driver. 
I tried disabling pango with no effect.
The high X CPU still occurs even with firefox minimised so I don't think it is
due to the X driver code trying to repaint the screen.

I guess this is really an upstream issue since I see the same with the
mozilla.org 2.0.0.1 i686 binary release. Let me know if you want me to open a
bug at mozilla.org.
Comment 1 Matěj Cepl 2007-02-27 15:51:03 EST
Yes, please, and let us know the number of the new bug (it would be nice of you
to search bugzilla.mozilla.org first to find out whether there isn't duplicate
bug of the same issue).
Comment 2 Jon Burgess 2007-03-01 16:45:26 EST
I see the same with the trunk mozilla 3.0a3pre. Did a quick search in bz.moz.org
for CPU and tabbed browsing and while there are lots of high firefox CPU bugs
reported none seem to be specific to X CPU and loading tabbed pages. Raised a
new bug https://bugzilla.mozilla.org/show_bug.cgi?id=372306
Comment 3 Matěj Cepl 2007-03-08 11:51:29 EST
OK, so I am closing this as an upstream bug. Thanks for the info.

Note You need to log in before you can comment on or make changes to this bug.