Bug 229160 - mkinitrd fails when invoked from rescue image (LVM not initialized)
mkinitrd fails when invoked from rescue image (LVM not initialized)
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
David Lawrence
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-18 20:11 EST by Carl Roth
Modified: 2008-05-06 15:14 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 15:14:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Carl Roth 2007-02-18 20:11:40 EST
Description of problem:

I just went through a horrible experience with my FC6 machine after a
motherboard update; the SATA chipset changed and I had to regenerate the initrd
to compensate.

The problem was that the 'chroot' environment that you get from the rescue CD
doesn't include full LVM support (lvdisplay et al.).  As a result, the ramdisk
files generated by 'mkinitrd' do not initialize LVM, and the resulting system is
unbootable.

I've noticed this problem before when I tried to *rename* the VG containing the
root filesystem.  Again, when I run chroot+initrd from the rescue image, it
mistakenly thinks that there are no VGs and no LVM is needed.

The workaround I used was to edit the 'mkinitrd' script to explicitly seed the
list of VGs that need to be enabled in the boot-time 'nash' script.

I think that this should be a command-line switch to mkinitrd, i.e.:

  mkinitrd ... --force-lvm --with-vg=VolGroup00 ...

Otherwise, is there a preferred method to regenerate the ramdisk?  Running
'mkinitrd' from rescue environment (outside of the chroot) doesn't work either.

Version-Release number of selected component (if applicable):

  mkinitrd-5.1.19.0.2-1

How reproducible:

Always

Steps to Reproduce:
1. Reboot a system with an LVM root using the rescue CD
2. chroot to the disk with

     chroot /mnt/sysimage'

3. regenerate the ramdisk with

     kver='2.6.19.blahblahblah`
     qf='%{RPMTAG_POSTIN}'
     eval `rpm -q --queryformat "$qf" kernel-$kver`

4. check the contents of the ramdisk with

     gzip -dc /boot/initrd-$kver.img | cpio -t

5. reboot (and witness the failure to find the root filesystem)

Actual results:


Expected results:


Additional info:
Comment 1 Bug Zapper 2008-04-04 02:17:12 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 2 Bug Zapper 2008-05-06 15:14:56 EDT
This bug is open for a Fedora version that is no longer maintained and
will not be fixed by Fedora. Therefore we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen thus bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.