Bug 229178 - vim helpgrep unable to search fedora-packaged compressed vim helpfiles
vim helpgrep unable to search fedora-packaged compressed vim helpfiles
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: vim (Show other bugs)
7
All Linux
medium Severity high
: ---
: ---
Assigned To: Karsten Hopp
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-19 06:23 EST by Scott R. Godin
Modified: 2008-03-03 13:38 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-03 13:38:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott R. Godin 2007-02-19 06:23:31 EST
Description of problem:
The use of vim's 'helpgrep' command to search through the files in the help 
system has been completely curtailed by the fact that the package maintainer(s) 
saw fit to gzip all the helpfiles, while failing to code/patch the additional 
functionality into vim to enable its builtin helpgrep command to search them 
thusly. It is, as they say these days, "made of 100% fail".

Version-Release number of selected component (if applicable):
vim-common-7.0.042-0.fc5

How reproducible:
every time

Steps to Reproduce:
1. open vim
2. :helpgrep omni (to find text on omni-completion), or any other common 
keyword one would normally use helpgrep to search the extensive vim 
documentation for.

Actual results:
E480: No match: omni 

Expected results:
list of documents containing the searched for keyword that you can step through.

Additional info:
Solution: Files from vim-common in /usr/share/vim/vim70/doc/ should not be 
gzipped by the packager, OR should be post-install-scripted in the rpm package 
to be ungzipped (if the reasoning is to decrease the size of the rpm for 
download/ISO storage reasons, which I find sensible) although I suspect that 
breaks the ability to rpm -V the package, 

Until the package maintainer(s) should see fit to add extra coding to vim that 
enables it to search through a gzipped doc file, it is probably better all-
around to leave them uncompressed as they are in the original.

Thank you.
Comment 1 Till Maas 2008-01-06 08:34:07 EST
This is still an issue with Fedora 7
Comment 2 Scott R. Godin 2008-01-12 08:35:14 EST
This is still an issue with Fedora 8

8:25am {3} localhost:/home/scott.g>$ rpm -q fedora-release
fedora-release-8-5
8:25am {4} localhost:/home/scott.g>$ rpm -qa vim\*
vim-X11-7.1.135-1.fc8
vim-minimal-7.1.135-1.fc8
vim-common-7.1.135-1.fc8
vim-enhanced-7.1.135-1.fc8
Comment 3 Scott R. Godin 2008-02-05 15:58:04 EST
workaround: 

 $> su -
 #> cd /usr/share/vim/vim71/doc/
 #> gunzip *.gz
 #> vim help.txt

and once within vim run

 :helptags /usr/share/vim/vim71/doc/

after that both :help AND :helpgrep will work properly

it would be _better_ however, to not have to do this.
Comment 4 Karsten Hopp 2008-03-03 13:38:39 EST
this works in vim-7.1.266-1.fc9

Note You need to log in before you can comment on or make changes to this bug.