Bug 229309 - memory leak? after disconnecting output device in pulseaudio manager while playing
memory leak? after disconnecting output device in pulseaudio manager while pl...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: exaile (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Deji Akingunola
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-20 03:01 EST by Yijun Yuan
Modified: 2009-07-14 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 12:53:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yijun Yuan 2007-02-20 03:01:16 EST
Description of problem:
memory leak? after disconnecting output device in pulseaudio manager while playing


Version-Release number of selected component (if applicable):
0.2.8-2.fc7

How reproducible:
everytime gstreamer client is disconnected from paman while playing

Steps to Reproduce:
1. start playing
2. disconnect "gstreamer client" in paman, the PulseAudio manager
3.
  
Actual results:
exaile loses response and continues to take a lot of memory. Sooner of later it
will take up all of the memory and swap. Still be able to switch to a terminal
and kill exaile process, though the computer is so slow to do that.

Expected results:
stop playing and prompt sound device not available, or try to connect the pipe
again.

Additional info:
pulse-audio version 0.9.5
Comment 1 Deji Akingunola 2007-07-12 21:04:45 EDT
Can you please check if this still happens with latest version of exaile,
exaile-0.2.10. Thanks.
Comment 2 Yijun Yuan 2007-07-12 21:41:52 EDT
exaile-0.2.10-1.fc8, paman-0.9.3-2.fc6, pulseaudio-0.9.6-2.fc8

Well, I tried three times. The first time it no longer eats memory. The exaile
UI lost response, playback stopped as well. The second and the third time the
system memory usage keeps increasing, I can see from "top" that the memory is
mainly taken by python.
Comment 3 Deji Akingunola 2008-01-20 18:04:15 EST
Can you please re-check if this bug is still present on F-8 with
exaile-0.2.11.1-1.fc8 . I'm inclined this is rather a problem with gstreamer
rather than exaile.

PS: I've tried to reproduce the bug myself, but I can't as I cannot find the
'paman' package in the fedora rawhide repo. Has the name changed? or do you know
the equivalent package in Fedora that provide its function.
Comment 4 Bug Zapper 2008-05-13 22:38:16 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Bug Zapper 2009-06-09 18:28:04 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Bug Zapper 2009-07-14 12:53:06 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.