Bug 229422 - fdGetFp: Assertion `fd && fd->magic == 0x04463138' failed
fdGetFp: Assertion `fd && fd->magic == 0x04463138' failed
Status: CLOSED DUPLICATE of bug 167483
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-20 17:31 EST by Robert Scheck
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-18 14:18:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2007-02-20 17:31:02 EST
Description of problem:
I know, this is not really a bug, but isn't it possible either to fix this 
problem or to print a better error message?

$ rpm2cpio http://download.fedora.redhat.com/pub/fedora/linux/core/6/i386/os/
Fedora/RPMS/vim-minimal-7.0.109-3.i386.rpm
rpm2cpio: ./rpmio_internal.h:301: fdGetFp: Assertion `fd && fd->magic == 
0x04463138' failed.
$ 

$ rpm2cpio http://download.fedora.redhat.com/pub/fedora/linux/core/6/i386/os/
Fedora/RPMS/vim-minimal-7.0.109-3.i386.rpm
rpm2cpio: ./rpmio_internal.h:352: fdGetFp: Assertion `fd && fd->magic == 
0x04463138' failed.
Abgebrochen
$ 

("Abgebrochen" means "canceled").

Version-Release number of selected component (if applicable):
rpm-4.4.2-32
rpm-4.4.8-1

How reproducible:
Everytime, see above.

Actual results:
Strange error message ;-)

Expected results:
Better error message or working stuff...
Comment 1 Jeff Johnson 2007-02-20 21:52:02 EST
Fixed (by replacing rpm2cpio.c with rpm2cpio.sh) in rpm cvs, will be in rpm-4.4.9-0.1 when built.

UPSTREAM
Comment 2 Jeff Johnson 2007-02-20 23:21:20 EST
This is a dupe of #167483 which claims (erroneously) that the problem is FIXED.
Comment 3 Panu Matilainen 2007-07-18 14:18:57 EDT
Yes it's a dupe, and yes it is actually fixed in F7 (by not using neon
transport) and also with neon in 4.4.2.1 in rawhide.

*** This bug has been marked as a duplicate of 167483 ***
Comment 4 Jeff Johnson 2007-07-18 14:24:50 EDT
replacing != fixing, accept no substitutes.
Comment 5 Robert Scheck 2007-07-18 14:29:28 EDT
As rpm.org is just one RPM upstream and not THE upstream and as I'm not using 
rpm.org's rpm, I don't care about this. Finally this bug report was initially 
meant for what is now rpm5.org... ;-)

Note You need to log in before you can comment on or make changes to this bug.