Bug 229522 - Init script does not work with debug kernels
Init script does not work with debug kernels
Product: Fedora
Classification: Fedora
Component: kexec-tools (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Neil Horman
Depends On:
  Show dependency treegraph
Reported: 2007-02-21 13:22 EST by Orion Poplawski
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-02-21 14:27:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2007-02-21 13:22:32 EST
Description of problem:

kdump init script does not startup properly when running debug kernels.  The
following fixes:

--- kdump.init  8 Mar 2006 20:39:23 -0000       1.8
+++ kdump.init  21 Feb 2007 18:20:58 -0000
@@ -49,7 +49,7 @@
        if [ -z "$KDUMP_KERNELVER" ]; then
                local running_kernel=`uname -r`

-               kdump_kver=`echo $running_kernel | sed 's/smp//g'`
+               kdump_kver=`echo $running_kernel | sed -e 's/smp//g' -e

Also is an issue on FC6.  Also, not sure if something similar needs to be done
for xen kernels.
Comment 1 Neil Horman 2007-02-21 14:27:14 EST
This is precisely what KDUMP_KERNELVER is for.  You can set it in

xen kernels currently do not support kdump
Comment 2 Orion Poplawski 2007-02-21 16:04:46 EST
But won't older kdump kernels eventually be removed by yum/installonly, thus
requiring periodic manual updating of /etc/sysconfig/kdump?  You already have to
do some munging for smp kernels, although I guess that's going away.  Seems like
an easy enough fix in any case.

Note You need to log in before you can comment on or make changes to this bug.