Bug 229582 - Yum / Yumex fatal exception error
Yum / Yumex fatal exception error
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
6
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
: 229530 229575 229602 229725 229758 234412 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-21 16:40 EST by Tim McConnell
Modified: 2014-01-21 17:57 EST (History)
7 users (show)

See Also:
Fixed In Version: 3.0.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-02 10:58:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Yumex fatal exception error output (1.80 KB, text/plain)
2007-02-21 16:40 EST, Tim McConnell
no flags Details
error output from Software Updater (1.60 KB, text/plain)
2007-02-21 16:50 EST, Tim McConnell
no flags Details

  None (edit)
Description Tim McConnell 2007-02-21 16:40:20 EST
Description of problem:
When attempting to update the system using yum or yumex both programs throw a
fatal exception errror 

Version-Release number of selected component (if applicable):
yum 3.0.3

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:
[tmick@red1 ~]$ sudo yum -y update
Loading "fedorakmod" plugin
Loading "priorities" plugin
Loading "fastestmirror" plugin
Loading "skip-broken" plugin
Loading "protectbase" plugin
Loading "kernel-module" plugin
Loading "changelog" plugin
Loading "installonlyn" plugin
Loading "tsflags" plugin
Loading "allowdowngrade" plugin
Loading "downloadonly" plugin
Setting up Update Process
Setting up repositories
Determining fastest mirrors
Reading repository metadata in from local files
0 packages excluded due to repository priority protections
0 packages excluded due to repository protections
Resolving Dependencies
/usr/lib/yum-plugins/kernel-module.py:61: DeprecationWarning: getHdrList() will
go away in a future version of Yum.

  for hdr in conduit.getRpmDB().getHdrList():
--> Populating transaction set with selected packages. Please wait.
---> Package audit-libs.i386 0:1.4.1-1.fc6 set to be updated
---> Package spamassassin.i386 0:3.1.8-2.fc6 set to be updated
---> Package php-ldap.i386 0:5.1.6-3.4.fc6 set to be updated
---> Package selinux-policy-mls.noarch 0:2.4.6-40.fc6 set to be updated
---> Package ekiga.i386 0:2.0.5-2.fc6 set to be updated
---> Package selinux-policy.noarch 0:2.4.6-40.fc6 set to be updated
---> Package php.i386 0:5.1.6-3.4.fc6 set to be updated
---> Package audit.i386 0:1.4.1-1.fc6 set to be updated
---> Package php-odbc.i386 0:5.1.6-3.4.fc6 set to be updated
---> Package php-mbstring.i386 0:5.1.6-3.4.fc6 set to be updated
---> Package php-common.i386 0:5.1.6-3.4.fc6 set to be updated
---> Package selinux-policy-devel.noarch 0:2.4.6-40.fc6 set to be updated
---> Package php-cli.i386 0:5.1.6-3.4.fc6 set to be updated
---> Package php-mysql.i386 0:5.1.6-3.4.fc6 set to be updated
---> Package selinux-policy-strict.noarch 0:2.4.6-40.fc6 set to be updated
---> Package audit-libs-python.i386 0:1.4.1-1.fc6 set to be updated
---> Package selinux-policy-targeted.noarch 0:2.4.6-40.fc6 set to be updated
---> Package php-pdo.i386 0:5.1.6-3.4.fc6 set to be updated
--> Running transaction check
--> Processing Dependency: opal >= 2.2.5 for package: ekiga
--> Processing Dependency: libpt_linux_x86_r.so.1.10.4 for package: ekiga
--> Processing Dependency: pwlib >= 1.10.4 for package: ekiga
--> Finished Dependency Resolution
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 135, in main
    (result, resultmsgs) = base.buildTransaction() 
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 442, in
buildTransaction
    self.plugins.run('postresolve', rescode=rescode, restring=restring)
  File "/usr/lib/python2.4/site-packages/yum/plugins.py", line 153, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/fedorakmod.py", line 273, in postresolve_hook
    newKernels + installedKernels)
  File "/usr/lib/yum-plugins/fedorakmod.py", line 228, in installAllKmods
    table = resolveVersions(interesting + modules)
  File "/usr/lib/yum-plugins/fedorakmod.py", line 152, in resolveVersions
    elif sameName == None:
  File "/usr/lib/python2.4/site-packages/yum/packages.py", line 191, in __eq__
    if comparePoEVR(self, other) == 0 and self.arch == other.arch and self.name
== other.name:
  File "/usr/lib/python2.4/site-packages/yum/packages.py", line 35, in comparePoEVR
    (e2, v2, r2) = (po2.epoch, po2.ver, po2.rel)
AttributeError: 'NoneType' object has no attribute 'epoch'


Expected results:
To be able to update the OS 

Additional info:Yumex error is in file yumex_whoops.txt
Comment 1 Tim McConnell 2007-02-21 16:40:20 EST
Created attachment 148539 [details]
Yumex fatal exception error output
Comment 2 Tim McConnell 2007-02-21 16:50:54 EST
Created attachment 148542 [details]
error output from Software Updater 

this also affects Software updater apparently
Comment 3 Jeremy Katz 2007-02-21 17:06:14 EST
This is a bug in the fedorakmod plugin
Comment 4 Jeremy Katz 2007-02-21 17:08:44 EST
*** Bug 229530 has been marked as a duplicate of this bug. ***
Comment 5 Jeremy Katz 2007-02-21 17:09:10 EST
*** Bug 229575 has been marked as a duplicate of this bug. ***
Comment 6 Tim McConnell 2007-02-22 01:17:17 EST
(In reply to comment #3)
> This is a bug in the fedorakmod plugin

I disabled the plugin and was able to update my system please advise when the
fix will be available. 
Comment 7 Jeremy Katz 2007-02-22 10:15:49 EST
*** Bug 229602 has been marked as a duplicate of this bug. ***
Comment 8 Stephen O. Gombosi 2007-02-22 18:19:09 EST
*** Bug 229725 has been marked as a duplicate of this bug. ***
Comment 9 A S Alam 2007-02-23 03:28:55 EST
*** Bug 229758 has been marked as a duplicate of this bug. ***
Comment 10 Robert Auger 2007-03-28 03:53:54 EDT
(In reply to comment #9)
> *** Bug 229758 has been marked as a duplicate of this bug. ***

(In reply to comment #0)
> Description of problem:
> When attempting to update the system using yum or yumex both programs throw a
> fatal exception errror 
> 
> Version-Release number of selected component (if applicable):
> yum 3.0.3
> 
> How reproducible:
> 
> 
> Steps to Reproduce:
> 1.
> 2.
> 3.
>   
> Actual results:
> [tmick@red1 ~]$ sudo yum -y update
> Loading "fedorakmod" plugin
> Loading "priorities" plugin
> Loading "fastestmirror" plugin
> Loading "skip-broken" plugin
> Loading "protectbase" plugin
> Loading "kernel-module" plugin
> Loading "changelog" plugin
> Loading "installonlyn" plugin
> Loading "tsflags" plugin
> Loading "allowdowngrade" plugin
> Loading "downloadonly" plugin
> Setting up Update Process
> Setting up repositories
> Determining fastest mirrors
> Reading repository metadata in from local files
> 0 packages excluded due to repository priority protections
> 0 packages excluded due to repository protections
> Resolving Dependencies
> /usr/lib/yum-plugins/kernel-module.py:61: DeprecationWarning: getHdrList() will
> go away in a future version of Yum.
> 
>   for hdr in conduit.getRpmDB().getHdrList():
> --> Populating transaction set with selected packages. Please wait.
> ---> Package audit-libs.i386 0:1.4.1-1.fc6 set to be updated
> ---> Package spamassassin.i386 0:3.1.8-2.fc6 set to be updated
> ---> Package php-ldap.i386 0:5.1.6-3.4.fc6 set to be updated
> ---> Package selinux-policy-mls.noarch 0:2.4.6-40.fc6 set to be updated
> ---> Package ekiga.i386 0:2.0.5-2.fc6 set to be updated
> ---> Package selinux-policy.noarch 0:2.4.6-40.fc6 set to be updated
> ---> Package php.i386 0:5.1.6-3.4.fc6 set to be updated
> ---> Package audit.i386 0:1.4.1-1.fc6 set to be updated
> ---> Package php-odbc.i386 0:5.1.6-3.4.fc6 set to be updated
> ---> Package php-mbstring.i386 0:5.1.6-3.4.fc6 set to be updated
> ---> Package php-common.i386 0:5.1.6-3.4.fc6 set to be updated
> ---> Package selinux-policy-devel.noarch 0:2.4.6-40.fc6 set to be updated
> ---> Package php-cli.i386 0:5.1.6-3.4.fc6 set to be updated
> ---> Package php-mysql.i386 0:5.1.6-3.4.fc6 set to be updated
> ---> Package selinux-policy-strict.noarch 0:2.4.6-40.fc6 set to be updated
> ---> Package audit-libs-python.i386 0:1.4.1-1.fc6 set to be updated
> ---> Package selinux-policy-targeted.noarch 0:2.4.6-40.fc6 set to be updated
> ---> Package php-pdo.i386 0:5.1.6-3.4.fc6 set to be updated
> --> Running transaction check
> --> Processing Dependency: opal >= 2.2.5 for package: ekiga
> --> Processing Dependency: libpt_linux_x86_r.so.1.10.4 for package: ekiga
> --> Processing Dependency: pwlib >= 1.10.4 for package: ekiga
> --> Finished Dependency Resolution
> Traceback (most recent call last):
>   File "/usr/bin/yum", line 29, in ?
>     yummain.main(sys.argv[1:])
>   File "/usr/share/yum-cli/yummain.py", line 135, in main
>     (result, resultmsgs) = base.buildTransaction() 
>   File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 442, in
> buildTransaction
>     self.plugins.run('postresolve', rescode=rescode, restring=restring)
>   File "/usr/lib/python2.4/site-packages/yum/plugins.py", line 153, in run
>     func(conduitcls(self, self.base, conf, **kwargs))
>   File "/usr/lib/yum-plugins/fedorakmod.py", line 273, in postresolve_hook
>     newKernels + installedKernels)
>   File "/usr/lib/yum-plugins/fedorakmod.py", line 228, in installAllKmods
>     table = resolveVersions(interesting + modules)
>   File "/usr/lib/yum-plugins/fedorakmod.py", line 152, in resolveVersions
>     elif sameName == None:
>   File "/usr/lib/python2.4/site-packages/yum/packages.py", line 191, in __eq__
>     if comparePoEVR(self, other) == 0 and self.arch == other.arch and self.name
> == other.name:
>   File "/usr/lib/python2.4/site-packages/yum/packages.py", line 35, in
comparePoEVR
>     (e2, v2, r2) = (po2.epoch, po2.ver, po2.rel)
> AttributeError: 'NoneType' object has no attribute 'epoch'
> 
> 
> Expected results:
> To be able to update the OS 
> 
> Additional info:Yumex error is in file yumex_whoops.txt

Is there a way to update fedora kernel without this plugin ?
Comment 11 Tim Lauridsen 2007-03-28 04:18:59 EDT
This error is caused by an error in yum, it is fixed upstream and released in
yum-3.0.4.

it looks like yum-3.0.4 & yum-3.0.5 only has been released in FC6 updates-testing

http://download.fedora.redhat.com/pub/fedora/linux/core/updates/testing/6/i386/

Jeremy: 
Is it possible to have yum-3.0.5 pushed to fedora 6 updates, so we can close
this one.

Comment 12 Tim Lauridsen 2007-03-30 03:16:05 EDT
*** Bug 234412 has been marked as a duplicate of this bug. ***
Comment 13 Tim Lauridsen 2007-03-30 03:19:32 EDT
Run this as root to solve the issue.

yum --enablerepo=updates-testing update yum

this will update yum to 3.0.5.
Comment 14 Tim Lauridsen 2007-03-30 03:49:58 EDT
Changed component to yum
Comment 15 Brian Morrison 2007-03-30 05:26:46 EDT
Using yum to update itself fails with the same error.

A direct rpm -Uvh <package-name(s)> using the yum packages from updates-testing
works OK.

Comment 16 Tim Lauridsen 2007-03-30 07:04:19 EDT
(In reply to comment #15)
> Using yum to update itself fails with the same error.
> 
> A direct rpm -Uvh <package-name(s)> using the yum packages from updates-testing
> works OK.
> 
> 

yum --noplugins --enablerepo=updates-testing update yum

should do it, without errors.
Comment 17 Jeremy Katz 2007-04-02 10:58:41 EDT
yum 3.0.5 has been pushed.

Note You need to log in before you can comment on or make changes to this bug.