Bug 229635 - spamassassin-3.1.8 / Archive::Tar missing from distro, is dep for sa-update
spamassassin-3.1.8 / Archive::Tar missing from distro, is dep for sa-update
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: spamassassin (Show other bugs)
4.0
All Linux
medium Severity low
: ---
: ---
Assigned To: Warren Togami
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-22 07:06 EST by nathan r. hruby
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-22 14:17:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nathan r. hruby 2007-02-22 07:06:53 EST
Description of problem:
The bump of spamassassin in RHEL4 to version 3.1.8 (via bug 228586) adds a new
command, sa-update (thanks!  Wheee!).  Sadly sa-update seems to have a runtime
dependancy in Archive::Tar which isn't shipped in stock RHEL making sa-update
kinda busted up.  

Suggest adding Archive::Tar, else nuking sa-update from the build for RHEL if
adding perl-Archive-Tar isn't in the cards.  Better to have no command than a
broken one :)

Version-Release number of selected component (if applicable):
3.1.8

How reproducible:
always

Steps to Reproduce:
1.  sa-update --checkonly
  
Actual results:
sa-update fails to run due to missing Archive::Tar


Expected results:
sa-update happily downloads me some anti-spam hawtness

Additional info:
Comment 1 nathan r. hruby 2007-02-22 07:09:44 EST
somebox.dom# sa-update --checkonly
Can't locate Archive/Tar.pm in @INC (@INC contains:
/usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/5.8.5/i386-linux-thread-multi
/usr/lib/perl5/5.8.5 /usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.4/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.3/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.2/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.1/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl/5.8.4
/usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.8.2
/usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.8.0
/usr/lib/perl5/site_perl
/usr/lib/perl5/vendor_perl/5.8.4/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.3/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.2/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.1/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.4 /usr/lib/perl5/vendor_perl/5.8.3
/usr/lib/perl5/vendor_perl/5.8.2 /usr/lib/perl5/vendor_perl/5.8.1
/usr/lib/perl5/vendor_perl/5.8.0 /usr/lib/perl5/vendor_perl) at
/usr/bin/sa-update line 94.
BEGIN failed--compilation aborted at /usr/bin/sa-update line 94.
somebox.dom# up2date -i perl-Archive-Tar

Fetching Obsoletes list for channel: rhel-i386-as-4...

Fetching Obsoletes list for channel: rhel-i386-as-4-extras...

Fetching Obsoletes list for channel: rhn-tools-rhel-4-as-i386...

Fetching Obsoletes list for channel: local-site-custom-as-4-x86...

Fetching Obsoletes list for channel: someapp-extras-as-4-x86...

Fetching rpm headers...

Name                                    Version        Rel
----------------------------------------------------------


The following packages you requested were not found:
perl-Archive-Tar
somebox.dom# 
Comment 2 Warren Togami 2007-02-22 14:17:08 EST
Darn... that part of the errata text was removed before release.  You can
however read the same thing in the --changelog.

- Options for RHEL4
    * spamc/spamd cannot connect over IPv6 or SSL
    * sa-update is disabled
  The above functionality requires perl modules not included in RHEL4.
  You may still use them if you get those perl modules from elsewhere.
  RHEL5 ships these perl modules.

Sorry, these features are not supportable in RHEL4 because we can't add
additional modules.  Personally I can tell you that they are usable if you
install those modules, but you have to grab them from elsewhere, and we don't
support this feature if it breaks.

Note You need to log in before you can comment on or make changes to this bug.