Bug 22972 - incorrect code from block clear
incorrect code from block clear
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.0
alpha Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
David Lawrence
:
Depends On:
Blocks: 21891
  Show dependency treegraph
 
Reported: 2000-12-29 01:26 EST by Richard Henderson
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-12 11:11:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch vs config/alpha/alpha.c; details and changelog enclosed. (3.39 KB, patch)
2000-12-29 01:31 EST, Richard Henderson
no flags Details | Diff

  None (edit)
Description Richard Henderson 2000-12-29 01:26:00 EST
void foo(char *, char *);

void showinfo()
{
    char uname[33] = "", tty[38] = "/dev/";
    foo(uname, tty);
}

During initialization of tty, this test will take an unaligned access
fault.

Patch to fix this to be attached if I can figure out how...
Comment 1 Richard Henderson 2000-12-29 01:31:26 EST
Created attachment 6784 [details]
Patch vs config/alpha/alpha.c; details and changelog enclosed.
Comment 2 Jakub Jelinek 2000-12-29 05:23:19 EST
Thanks, patch added to patchset for next rpm build.
Comment 3 Jakub Jelinek 2001-01-21 13:20:15 EST
This made into 2.96-70 already (ie. since Jan, 4th).

Note You need to log in before you can comment on or make changes to this bug.