Bug 22981 - LPRngTool: dosn't work with mor than on printer
Summary: LPRngTool: dosn't work with mor than on printer
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: distribution   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Crutcher Dunnavant
QA Contact: David Lawrence
URL:
Whiteboard: Florence Gold
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-29 12:19 UTC by Gerald Teschl
Modified: 2007-04-18 16:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-04 22:50:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gerald Teschl 2000-12-29 12:19:53 UTC
There is no BUGZILLA entry for LPRngTool!

Subject line says it all. It looks like the newline after each
comment is ommitted. Hence the line after the comment will be
added to the comment. Renering the file invalid.

Even if I fix the printcap by hand. LPRng will break it the
first time it is invoked.

Original printcap:
----------------------------------------
lp|zra:\
        :sd=/var/spool/lpd/lp-ps:\
        :mx#0:\
        :sh:\
        :rm=zra.mat.univie.ac.at:\
        :rp=lp:\
        :if=/var/spool/lpd/lp-ps/filter:
##PRINTTOOL3## REMOTE POSTSCRIPT 600x600 a4 {} PostScript Default {}
cousteau:\
        :sd=/var/spool/lpd/lp-ps:\
        :mx#0:\
        :sh:\
        :rm=cousteau.mat.univie.ac.at:\
        :rp=lp:\
       
:if=/var/spool/lpd/lp-ps/filter:                                        

After conversion
-----------------------
##LPRNGTOOL## REMOTE POSTSCRIPT 1200x1200 a4 {} PostScript Default {}
lp|zra
:sd=/var/spool/lpd/lp-ps
:mx#0
:sh
:rm=zra.mat.univie.ac.at
:rp=lp
:if=/var/spool/lpd/lp-ps/filter
:##LPRNGTOOL## REMOTE POSTSCRIPT 600x600 a4 {} PostScript Default
{}cousteau
:sd=/var/spool/lpd/lp-ps
:mx#0
:sh
:rm=cousteau.mat.univie.ac.at
:rp=lp
:if=/var/spool/lpd/lp-ps/filter
:#

Comment 1 Glen Foster 2001-01-11 21:05:16 UTC
This defect is considered MUST-FIX for Florence Gold release

Comment 2 Crutcher Dunnavant 2001-02-04 22:50:45 UTC
We will not be shipping LPRngTool, so I am closing this wontfix


Note You need to log in before you can comment on or make changes to this bug.