This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 229835 - yum update fails: missing dependency for yum-utils
yum update fails: missing dependency for yum-utils
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
6
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-23 13:41 EST by Dick Franks
Modified: 2014-01-21 17:57 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-26 04:18:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dick Franks 2007-02-23 13:41:12 EST
Description of problem:
Attempt to update fc6 system using yum stalls at dependency check

Version-Release number of selected component (if applicable):
yum-utils.noarch 0:1.1.1-1.fc7 occuring in fc6 update stream

How reproducible:
100%

Steps to Reproduce:
1. su - root
2. yum update
3.
  
Actual results:
...
---> Package bzip2-devel.i386 0:1.0.3-6.fc6 set to be updated
---> Package pam-devel.i386 0:0.99.6.2-3.16.fc6 set to be updated
---> Package yum-utils.noarch 0:1.1.1-1.fc7 set to be updated
--> Running transaction check
--> Processing Dependency: yum >= 3.1.1 for package: yum-utils
--> Finished Dependency Resolution
Error: Missing Dependency: yum >= 3.1.1 is needed by package yum-utils

Expected results:
---> Package yum-utils.noarch 0:1.1.1-1.FC6 set to be updated

Additional info:
FC7 version of yum-utils seems to have been added to FC6 update stream
Comment 1 Dick Franks 2007-02-23 14:22:50 EST
My description of problem was inaccurate. I had failed to spot that package
yum-utils.noarch-1.0.2-2.fc7 had been installed with some earlier batch of
updates. Yum acted on this misinformation.

Immediate problem solved by
    yum remove yum-utils

Comment 2 Tim Lauridsen 2007-02-26 04:18:22 EST
yum-util-1.1.x is only available in Fedora Extras Development.
yum-utils-1.0.3 is the latest release for FC6.
You must have have install/updated yum-utils, with the the Fedora Extras
Development active.

Comment 3 Dick Franks 2007-02-26 14:45:46 EST
(In reply to comment #2)
> yum-util-1.1.x is only available in Fedora Extras Development.
> yum-utils-1.0.3 is the latest release for FC6.
> You must have have install/updated yum-utils, with the the Fedora Extras
> Development active.

Did not knowingly install this package, (a) I have no need for it, (b) neither 
would I have chosen FC7 package for use on FC6 system.
You are correct in thinking that Extras Development is active, there are a 
couple of packages installed from there to solve application problems.
I suspect someone made a mistake since 6th Nov, which I was unfortunate enough 
to bump into, but the problem has gone away which is all that matters.

Note You need to log in before you can comment on or make changes to this bug.