This service will be undergoing maintenance at 03:30 UTC, 2016-05-27. It is expected to last about 2 hours
Bug 229917 - yum update not possible
yum update not possible
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
6
x86_64 Linux
medium Severity urgent
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
: 229924 230021 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-24 05:11 EST by Oliver Ratz
Modified: 2014-01-21 17:57 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-10 11:53:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Make compare handle None (390 bytes, patch)
2007-02-27 11:15 EST, Jack Neely
no flags Details | Diff

  None (edit)
Description Oliver Ratz 2007-02-24 05:11:45 EST
Description of problem:
trying to update anything with yum gives me the error:
i rebuild the db with rpm --rebuilddb
cleaning all of yum
yum clean all
but im not able to update anything 

--> Running transaction check
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 135, in main
    (result, resultmsgs) = base.buildTransaction() 
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 442, in
buildTransaction
    self.plugins.run('postresolve', rescode=rescode, restring=restring)
  File "/usr/lib/python2.4/site-packages/yum/plugins.py", line 153, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/fedorakmod.py", line 273, in postresolve_hook
    newKernels + installedKernels)
  File "/usr/lib/yum-plugins/fedorakmod.py", line 216, in installAllKmods
    rModules = resolveVersions(modules)
  File "/usr/lib/yum-plugins/fedorakmod.py", line 152, in resolveVersions
    elif sameName == None:
  File "/usr/lib/python2.4/site-packages/yum/packages.py", line 191, in __eq__
    if comparePoEVR(self, other) == 0 and self.arch == other.arch and self.name
== other.name:
  File "/usr/lib/python2.4/site-packages/yum/packages.py", line 35, in comparePoEVR
    (e2, v2, r2) = (po2.epoch, po2.ver, po2.rel)
AttributeError: 'NoneType' object has no attribute 'epoch'

Version-Release number of selected component (if applicable):yum-3.0.3-1.fc6


How reproducible:


Steps to Reproduce:
1. yum update
2.
3.
  
Actual results:


Expected results:


Additional info:
--> Running transaction check
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 135, in main
    (result, resultmsgs) = base.buildTransaction() 
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 442, in
buildTransaction
    self.plugins.run('postresolve', rescode=rescode, restring=restring)
  File "/usr/lib/python2.4/site-packages/yum/plugins.py", line 153, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/fedorakmod.py", line 273, in postresolve_hook
    newKernels + installedKernels)
  File "/usr/lib/yum-plugins/fedorakmod.py", line 216, in installAllKmods
    rModules = resolveVersions(modules)
  File "/usr/lib/yum-plugins/fedorakmod.py", line 152, in resolveVersions
    elif sameName == None:
  File "/usr/lib/python2.4/site-packages/yum/packages.py", line 191, in __eq__
    if comparePoEVR(self, other) == 0 and self.arch == other.arch and self.name
== other.name:
  File "/usr/lib/python2.4/site-packages/yum/packages.py", line 35, in comparePoEVR
    (e2, v2, r2) = (po2.epoch, po2.ver, po2.rel)
AttributeError: 'NoneType' object has no attribute 'epoch'
Comment 1 Jeremy Katz 2007-02-26 09:26:43 EST
*** Bug 230021 has been marked as a duplicate of this bug. ***
Comment 2 Tim Lauridsen 2007-02-27 02:44:27 EST
Hi Jack.

Do you have any clue what goes wrong in kmod plugin here ???

Tim
Comment 3 Tim Lauridsen 2007-02-27 02:46:07 EST
*** Bug 229924 has been marked as a duplicate of this bug. ***
Comment 4 Peter Trenholme 2007-02-27 09:54:54 EST
As I said in my bug report (229924) the priority of this bug should be fairly
low since the obvious work-around, to disable the fedorakmod plug in, avoids the
problem.

And installing any missing "kmod" rpms "by hand" is fairly easy, especially
since the problem only occurs when the "kmod" is being updated in place, not as
part of a kernel upgrade.
Comment 5 Jack Neely 2007-02-27 11:14:22 EST
Oliver:  What are the contents of /etc/yum/pluginconf.d/fedorakmod.conf and what
does the following rpm command return:

   rpm -qa|grep kmod

Seth: I'm comparing a package object to None.  The __eq__ method doesn't handle
that.  See attached patch.
Comment 6 Jack Neely 2007-02-27 11:15:27 EST
Created attachment 148870 [details]
Make compare handle None
Comment 7 Tim Lauridsen 2007-02-28 07:58:33 EST
Jack: I have added your patch to upstream CVS (HEAD & 3_0_X Branch).


Note You need to log in before you can comment on or make changes to this bug.