Bug 229942 - wlassistant.x86_64 0.5.6-1.fc6 hangs while connecting
wlassistant.x86_64 0.5.6-1.fc6 hangs while connecting
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: wlassistant (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-24 14:43 EST by Ken Barber
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-28 11:56:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ken Barber 2007-02-24 14:43:41 EST
Description of problem:
This version of wlassistant correctly detects wireless access points, but cannot
connect to any of them.

Version-Release number of selected component (if applicable):
0.5.6-1.fc6

How reproducible:
Always

Steps to Reproduce:
1.launch wlassistant
2.choose a wireless access point and click "connect"
3.watch it fail.
  
Actual results:

[root@localhost ~]# wlassistant
kdeinit: Launched DCOPServer, pid = 3194 result = 0
DCOP: register 'anonymous-3194' -> number of clients is now 1
DCOP: unregister 'anonymous-3194'
kdeinit: Launched KLauncher, pid = 3198 result = 0
DCOP: register 'klauncher' -> number of clients is now 1
DCOP: new daemon klauncher
kdeinit: opened connection to :0.0
kdeinit: Launched KDED, pid = 3199 result = 0
DCOP: register 'kded' -> number of clients is now 1
DCOP: unregister 'kded'
DCOP: register 'kded' -> number of clients is now 1
DCOP: register 'anonymous-3199' -> number of clients is now 2
Conflict in /usr/lib/kde3/plugins/styles/plastik.so:
  Plugin uses incompatible Qt library!
  expected build key "x86_64 Linux g++-4.* full-config", got "i686 Linux g++-4.*
full-config".
kdeinit: Got EXT_EXEC 'kbuildsycoca' from launcher.
DCOP: register 'kbuildsycoca' -> number of clients is now 3
kbuildsycoca running...
DCOP: register 'anonymous-3202' -> number of clients is now 4
Reusing existing ksycoca
DCOP: unregister 'anonymous-3202'
DCOP: unregister 'kbuildsycoca'
kdeinit: PID 3202 terminated.
kdeinit: Got EXEC_NEW 'kconf_update' from launcher.
kdeinit: PID 3217 terminated.
DCOP: new daemon kded
DCOP: unregister 'anonymous-3199'
kdeinit: PID 3199 terminated.
DCOP: register 'wlassistant-3190' -> number of clients is now 1
Loaded application options.
DHCP Client: dhclient
All executables found.
iwconfig_status: /sbin/iwconfig
==>stderr: lo        no wireless extensions.

eth0      no wireless extensions.

Wireless interface(s): eth1
Permissions checked.
ifconfig_status: /sbin/ifconfig eth1
ifup: /sbin/ifconfig eth1 up
scan: /sbin/iwlist eth1 scan
Networks found: 7
Checking for active connection.
Trying to get gateway address...
No DHCP client running.
...from 'route'
No default gateway.
ACTION: CONNECT.
Network settings updated.
No DHCP client running.
No pre-connection command specified.
ifup: /sbin/ifconfig eth1 up
iwconfig_set: /sbin/iwconfig eth1 mode managed channel 1 key off essid goesh
iwconfig_ap: /sbin/iwconfig eth1 ap 00:03:52:F2:14:50
ifconfig_dhcp: /sbin/dhclient eth1
==>stderr: Internet Systems Consortium DHCP Client V3.0.5-RedHat
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/eth1/00:14:a5:a6:e7:3c
Sending on   LPF/eth1/00:14:a5:a6:e7:3c
Sending on   Socket/fallback
DHCPREQUEST on eth1 to 255.255.255.255 port 67
DHCPREQUEST on eth1 to 255.255.255.255 port 67
DHCPACK from 172.17.1.1
bound to 172.17.147.247 -- renewal in 40064 seconds.
Running DHCP client found.
kill_dhcp: /sbin/dhclient -r eth1
==>stderr: Internet Systems Consortium DHCP Client V3.0.5-RedHat
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/eth1/00:14:a5:a6:e7:3c
Sending on   LPF/eth1/00:14:a5:a6:e7:3c
Sending on   Socket/fallback
DHCPRELEASE on eth1 to 172.17.1.1 port 67
CONNECTION FAILED.
Application options saved.
Kernel socket closed.
DCOP: unregister 'wlassistant-3190'
[root@localhost ~]# DCOPServer : slotTerminate() -> sending terminateKDE signal.
kdeinit: terminate KDE.
DCOP: unregister 'kded'
DCOP: unregister 'klauncher'
DCOPServer : slotSuicide() -> exit.


Expected results:

[root@localhost install]# rpm -e wlassistant
[root@localhost install]# rpm -ivh wlassistant-0.5.5-4.fc6.x86_64.rpm
Preparing...                ########################################### [100%]
   1:wlassistant            ########################################### [100%]
[root@localhost install]# wlassistant
kdeinit: Launched DCOPServer, pid = 3387 result = 0
DCOP: register 'anonymous-3387' -> number of clients is now 1
DCOP: unregister 'anonymous-3387'
kdeinit: Launched KLauncher, pid = 3391 result = 0
DCOP: register 'klauncher' -> number of clients is now 1
DCOP: new daemon klauncher
kdeinit: opened connection to :0.0
kdeinit: Launched KDED, pid = 3392 result = 0
DCOP: register 'kded' -> number of clients is now 1
DCOP: unregister 'kded'
DCOP: register 'kded' -> number of clients is now 1
kdeinit: Got EXT_EXEC 'kbuildsycoca' from launcher.
DCOP: register 'anonymous-3392' -> number of clients is now 2
DCOP: register 'kbuildsycoca' -> number of clients is now 3
kbuildsycoca running...
DCOP: register 'anonymous-3394' -> number of clients is now 4
Reusing existing ksycoca
DCOP: unregister 'anonymous-3394'
DCOP: unregister 'kbuildsycoca'
kdeinit: PID 3394 terminated.
kdeinit: Got EXEC_NEW 'kconf_update' from launcher.
kdeinit: PID 3395 terminated.
DCOP: new daemon kded
DCOP: unregister 'anonymous-3392'
kdeinit: PID 3392 terminated.
DCOP: register 'wlassistant-3384' -> number of clients is now 1
Loaded application options.
DHCP Client: dhclient
All executables found.
iwconfig_status: /sbin/iwconfig
==>stderr: lo        no wireless extensions.

eth0      no wireless extensions.

Wireless interface(s): eth1
Permissions checked.
ifconfig_status: /sbin/ifconfig eth1
ifup: /sbin/ifconfig eth1 up
scan: /sbin/iwlist eth1 scan
Networks found: 5
Checking for active connection.
Trying to get gateway address...
...from 'route'
No default gateway.
ACTION: CONNECT.
Network settings updated.
kill_dhcp: /sbin/dhclient -r eth1
==>stderr: Internet Systems Consortium DHCP Client V3.0.5-RedHat
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/eth1/00:14:a5:a6:e7:3c
Sending on   LPF/eth1/00:14:a5:a6:e7:3c
Sending on   Socket/fallback
DHCPRELEASE on eth1 to 172.17.1.1 port 67
send_packet: Network is unreachable
send_packet: please consult README file regarding broadcast address.
ifup: /sbin/ifconfig eth1 up
iwconfig_set: /sbin/iwconfig eth1 mode managed channel 1 key off essid goesh
iwconfig_ap: /sbin/iwconfig eth1 ap 00:03:52:F2:14:50
ifconfig_dhcp: /sbin/dhclient -q eth1
Trying to get gateway address...
...from 'route'
Gateway address: 172.17.1.1
Internet now accessible.
Application options saved.
Kernel socket closed.
DCOP: unregister 'wlassistant-3384'
[root@localhost install]# DCOPServer : slotTerminate() -> sending terminateKDE
signal.
DCOP: unregister 'kded'
DCOP: unregister 'klauncher'
kdeinit: terminate KDE.
DCOPServer : slotSuicide() -> exit.


Additional info:
Compaq Presario V2000 laptop, running 64-bit "hpsp33008" driver under
ndiswrapper.  wlassistant-0.5.5-4.fc6.x86_64 works perfectly.

Please contact me if you need any more troubleshooting done.
Comment 1 Tom "spot" Callaway 2007-04-10 12:54:16 EDT
Please retry with wlassistant 0.5.7-1.fc6, which was built this morning, and
should show up in the repositories either tonight or tomorrow.
Comment 2 Ken Barber 2007-07-28 11:56:06 EDT
Tom,

I'm sorry it took so long to get back to you on this.  Had to move, then move
again, etc.

It appears that the problem was actually in the WAP at the motel.  Apparently
the thing was changing ID's or MAC addresses or god-knows-what from time to time.

I don't remember now how I did it, but I found a way to clear all of
wlassistant's cached data, and I was able to resolve the problem, every time, by
doing that.

Apparently there was something in the Access Point(s) that I was using that
changed from time to time.

You can close this bug now, probably as NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.