Bug 230012 - kvm: $RPM_OPT_FLAGS not used
kvm: $RPM_OPT_FLAGS not used
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kvm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-25 17:53 EST by Ville Skyttä
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-26 16:00:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2007-02-25 17:53:46 EST
http://www.redhat.com/archives/fedora-maintainers/2007-January/msg00339.html

kvm is built without using $RPM_OPT_FLAGS.  qemu/Makefile appears to support
"make CFLAGS=..." builds, but user/Makefile doesn't (setting them that way will
override some needed options or they all need to be redefined) so the fix is a
bit more work than just that, preferably upstream...
Comment 1 Jeremy Katz 2007-02-25 18:23:45 EST
Note that we definitely don't want RPM_OPT_FLAGS used for the qemu portions
exactly for the same reasons that we don't want them for qemu in general (we're
using gcc 3.4).  kvmctl I'll have to look a little closer at to be more sure of
what we want to do.
Comment 2 Ville Skyttä 2007-02-26 13:44:45 EST
$RPM_OPT_FLAGS do not need to be used as is, but they should be used as the
basis and unwanted options filtered out instead of ignoring everything.  And
some options from current optflags work with gcc 3.4 too.  Rationale for
deviating from them should also be documented in the specfile.
http://fedoraproject.org/wiki/Packaging/Guidelines#CompilerFlags
Comment 3 Jeremy Katz 2007-02-26 16:00:48 EST
There was a long thread on fedora-devel-list about why qemu _can't_ use the
standard optflags if you want the dyngen stuff to keep working, though.  Only
partially due to gcc 3.4 (although istr there _are_ cases where things don't
work with gcc 3.4)

But made it so that we use RPM_OPT_FLAGS where it's appropriate to do so.

Note You need to log in before you can comment on or make changes to this bug.