Bug 230025 - Display corruption and hard hang with radeon driver on rawhide
Display corruption and hard hang with radeon driver on rawhide
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-25 19:52 EST by Bastien Nocera
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-02 10:56:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (43.59 KB, text/plain)
2007-02-25 19:52 EST, Bastien Nocera
no flags Details
lspci -v output (5.89 KB, text/plain)
2007-02-26 12:07 EST, Ray Van Dolson
no flags Details
Xorg log (65.73 KB, text/plain)
2007-02-26 12:09 EST, Ray Van Dolson
no flags Details
xorg configuration file (658 bytes, text/plain)
2007-02-26 12:09 EST, Ray Van Dolson
no flags Details
glxinfo output (3.98 KB, text/plain)
2007-02-26 12:11 EST, Ray Van Dolson
no flags Details
dmesg (16.15 KB, text/plain)
2007-02-26 12:11 EST, Ray Van Dolson
no flags Details

  None (edit)
Description Bastien Nocera 2007-02-25 19:52:27 EST
Linux localhost 2.6.20-1.2942.fc7 #1 SMP Fri Feb 23 00:04:17 EST 2007 i686 i686
i386 GNU/Linux

i686 kernel.

When starting up, the display would produce corruption at the top and bottom of
the picture, the cursor would be able to move for a couple of tens of seconds,
then would disappear as the machine is hard hung.

X log attached

xorg-x11-drv-ati-6.6.3-2.fc7

Disabling DRI (by adding the line "alias radeon off" in /etc/modprobe.conf)
makes 2D support work again.

DRI was working fine with the latest FC6 update.

The problem is likely to lie in the X.org part of the infrastructure, as the
latest FC6 kernel on a F7 system fails in the same way.
Comment 1 Bastien Nocera 2007-02-25 19:52:27 EST
Created attachment 148773 [details]
Xorg.0.log
Comment 2 Ray Van Dolson 2007-02-26 12:04:30 EST
I am also experiencing a similar (if not the same) issue.

Fresh install of FC6 exhibits this.  Even after applying all the "stable" errata
(nothing from rawhide), I cannot start X with DRI enabled.

ASUS A7V333 motherboard
ASUS Radeon (ATI Radeon 9800XT)

Using:

xorg-x11-drv-ati-6.6.3-1.fc6 and kernel 2.6.9-1.2911.fc6 (i686)

If I use alias radeon off, I can get into X, albeit with DRI disabled.

Will attach various system information.  Should I upgrade to rawhide kernel/ATI
drivers or is it more helpful to remain where I am with the FC6 updates?
Comment 3 Ray Van Dolson 2007-02-26 12:07:55 EST
Created attachment 148808 [details]
lspci -v output
Comment 4 Ray Van Dolson 2007-02-26 12:09:09 EST
Created attachment 148809 [details]
Xorg log

This is my Xorg log from an attempted X start with DRI enabled (alias radeon
off *not* present in modprobe.conf)
Comment 5 Ray Van Dolson 2007-02-26 12:09:33 EST
Created attachment 148810 [details]
xorg configuration file
Comment 6 Ray Van Dolson 2007-02-26 12:11:01 EST
Created attachment 148811 [details]
glxinfo output

This is from an instance of X with DRI disabled (alias radeon off in
modprobe.conf).  You can see DRI is off here and we are using MesaGL.
Comment 7 Ray Van Dolson 2007-02-26 12:11:44 EST
Created attachment 148813 [details]
dmesg
Comment 8 Bastien Nocera 2007-02-27 06:24:19 EST
Ray, this bug is about problems with the Fedora 7 devel version. Make sure your
machine is up-to-date, and running a i686 kernel (not i586). If the problem
persists, please file a new bug, and mention the exact versions of the kernel,
and xorg-x11-drv-ati
Comment 9 Matěj Cepl 2007-02-27 17:38:13 EST
Bastien, can I ask for /etc/X11/xorg.conf (if any) and running without any
/etc/X11/xorg.conf whatsoever? Thanks.

Ray, really please file a new bug, we cannot manage more than one issue under
one bug.
Comment 10 Ray Van Dolson 2007-02-27 21:08:56 EST
I'll file a new FC6-specific bug.
Comment 11 Matěj Cepl 2007-07-02 09:51:14 EDT
Bastien, I still haven't got my logs. Could you please either post them or to
confirm to me, that this has been fixed?
Comment 12 Bastien Nocera 2007-07-02 10:56:10 EDT
Richard has my laptop for now, and he tells me that it works fine. The problem
was probably related to the hardware problem I had with it.

Note You need to log in before you can comment on or make changes to this bug.