Bug 230037 - not well-formed (invalid token)
not well-formed (invalid token)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: perl-XML-Twig (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Robin Norwood
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-26 01:04 EST by David Highley
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-04 16:44:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Highley 2007-02-26 01:04:56 EST
Description of problem:
HTML Tree builder seems to have broken tv_grab_na_icons

Version-Release number of selected component (if applicable):
perl-HTML-Tree-3.23-1.fc6

How reproducible:


Steps to Reproduce:
1. tv_grab_na_icons
2. enter zip code
3.
  
Actual results:
Empty xml file

Expected results:


Additional info:
This has been fixed with the latest versions of HTML::TreeBuilder and
XML::Twig
Comment 1 David Highley 2007-04-01 14:25:10 EDT
There has been an update available for this package for quite a while now, is
the rpm going to be updated?
Comment 2 Tom "spot" Callaway 2007-04-01 17:41:23 EDT
Reassigning to perl-XML-Twig, as perl-HTML-Tree has been at the latest version
since late 2006. I can confirm that the perl-XML-Twig package in devel (F7)
resolves this bug (bug is in xmltv, not yet available as a Fedora package).
Comment 3 Tom "spot" Callaway 2007-04-01 17:42:36 EDT
To clarify, the bug is triggered by xmltv. That's where tv_grab_na_icons comes
from. Pushing the devel perl-XML-Twig package as an FC-6 update should resolve
this bug.
Comment 4 Robin Norwood 2007-04-02 14:26:08 EDT
Fair enough.  New version built (3.29-1) and seems to work fine.  It should be
available in 'updates-testing' in a few minutesI don't feel like installing
xmltv right now, so let me know if the new version doesn't fix your problem.
Comment 5 David Highley 2007-04-03 19:15:23 EDT
I can confirm that updating to version 3.29-1 of perl-XML-Twig fixed the issue
reported.
Comment 6 Robin Norwood 2007-04-04 11:09:18 EDT
Great, thanks - I've submitted it to the release team as an update for fc6.  fc7
will have 3.29 as well.

Note You need to log in before you can comment on or make changes to this bug.