Bug 230040 - Kernels since 2.6.18-1.2849 break xen nat setup
Summary: Kernels since 2.6.18-1.2849 break xen nat setup
Status: CLOSED DUPLICATE of bug 230038
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel-xen   
(Show other bugs)
Version: 6
Hardware: i386
OS: Linux
high
medium
Target Milestone: ---
Assignee: Xen Maintainance List
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-26 06:14 UTC by Daniel McNamara
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-26 13:42:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Daniel McNamara 2007-02-26 06:14:25 UTC
Description of problem:

Xen setup using natng not bridging for guests. Works fine on 2.6.18-1.2849 and
previous. Fails completly on all kernels since including the recent
2.6.19-1.2911. Note this only seems to be the fault of the Dom0 - kernels run by
the guests seem not to be relevant.

Version-Release number of selected component (if applicable): 2.6.19-1.2911


How reproducible:

Every time - each kernel since 2.6.18-1.2849

Steps to Reproduce:
1. Set up xen machines using nat network NOT standard bridging
2. Install any kernel above 2.6.18-1.2849 on Dom0
3. Start xen guests. Networks will come up but traffic will fail to flow to/from
the machines. Revert Dom0 to 2.6.18-1.2849 or below and it will work without issue.
  
Actual results:

Xen network nat fails to work - no errors/diagnositics to indicate why

Expected results:

Standard xen nat network setup should continue to work on newer kernels

Additional info:

I have tested this multiple times. At present my setup has Dom0 running
2.6.18-1.2849 and the DomU guests are running 2.6.18-1.2911 and this NAT's just
fine. Upgrade Dom0 to 2.6.18-1.2849 and xen guests start as normal. Everything
appears to be in place. Network traffic however does not flow. No other changes
in terms of xen configuration has been done.

Comment 1 Daniel Berrange 2007-02-26 13:42:35 UTC

*** This bug has been marked as a duplicate of 230038 ***


Note You need to log in before you can comment on or make changes to this bug.