Bug 23018 - APM restore fails to restart USB mouse
Summary: APM restore fails to restart USB mouse
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: apmd
Version: 7.0
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: Aaron Brown
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-30 03:18 UTC by Scott Cohen
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-05-19 21:07:23 UTC


Attachments (Terms of Use)

Description Scott Cohen 2000-12-30 03:18:23 UTC
I have an NEC Ready 440T laptop with two USB ports.  I recently purchased a
Kensington optical mouse that works both for USB and PS/2.  The system
detected it fine and reconfigured gpm and X perfectly.  The only problem
is, if I suspend the laptop and then restore it, the power to the mouse
does not go back on.  To use it again I must unplug the mouse and then plug
it back in.  I'm using a 2.2.18 kernel I compiled with usb-uhci module for
the controller.

I don't have any other USB devices so I don't know if this is a problem
between USB and APM or if it is somehow specific to mice or this one in
particular.

This glitch doesn't prevent the device from being used, it is just an
annoyance.  I'm sending this to RedHat rather than the kernel list or the
APM people because I'm not sure if it has something to do with the script
APM uses to shutdown and restart devices, and if so whether or not RedHat
wrote their own script.  (/etc/sysconfig/apm-scripts I believe).

I also can't tell you if this happens with Windows, I'm assuming it is a
Linux only problem.  If you need any more information let me know.

Thanks,
Scott Cohen
sbc25@cornell.edu

Comment 1 Scott Cohen 2001-01-11 05:38:05 UTC
I got kernel 2.4.0 and the problem is fixed.  Not sure exactly what was wrong,
maybe something in the USB backport?

Anyway, works fine now.

Comment 2 Bernhard Rosenkraenzer 2001-01-15 22:21:29 UTC
I don't have access to USB hardware; is there a special command you 
need to execute in order to restart USB devices, or should the USB 
modules be unloaded and re-loaded?


Comment 3 Bernhard Rosenkraenzer 2001-07-17 11:33:19 UTC
does unloading and reloading the mousedev module fix this for you?


Comment 4 Bill Nottingham 2003-05-19 21:07:23 UTC
closed, no response


Note You need to log in before you can comment on or make changes to this bug.