Bug 230206 - Pulseaudio default configuration refuses to run
Summary: Pulseaudio default configuration refuses to run
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: pulseaudio   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-27 14:44 UTC by Bastien Nocera
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-07 10:20:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bastien Nocera 2007-02-27 14:44:04 UTC
From a stock rawhide installation, try to run pulse-audio:
Feb 27 14:16:25 randel pulseaudio[3753]: main.c: pa_pid_file_create() failed.
Feb 27 14:16:25 randel pulseaudio[3747]: module.c: Failed to open module
"module-x11-bell": module-x11-bell.so: cannot open shared object file: No such
file or directory
Feb 27 14:16:25 randel pulseaudio[3747]: module.c: Failed to open module
"module-x11-publish": module-x11-publish.so: cannot open shared object file: No
such file or directory
Feb 27 14:16:25 randel pulseaudio[3747]: module.c: Failed to open module
"module-gconf": module-gconf.so: cannot open shared object file: No such file or
directory
Feb 27 14:16:25 randel pulseaudio[3747]: main.c: Module load failed.


The modules should be required either as dependencies, or builtin:
pulseaudio-module-gconf (for module-gconf)
pulseaudio-module-x11 (for module-x11-bell)
pulseaudio-module-zeroconf (for module-x11-publish)

Comment 1 Pierre Ossman 2007-03-02 09:55:20 UTC
Those modules are in a "nofail" section of the default configuration, so they do
not prevent startup.

Startup might be a bit noisy with those things missing, but it allows us to have
a configuration where the user just has to install the extra packages to get the
extra functionality.

The reason they're separate packages is that pulse isn't just used for the
desktop so we do not want to pull in everything but the kitchen sink.

Comment 2 Bastien Nocera 2007-03-02 09:58:35 UTC
Maybe the error message could be a bit clearer that it's not fatal.

Comment 3 Pierre Ossman 2007-03-02 11:52:14 UTC
Indeed, but it is technically difficult as the code that prints the error has no
idea if it is fatal or not.

Comment 4 Lennart Poettering 2007-05-28 20:47:06 UTC
PulseAudio 0.9.6 adds a new .ifexists directive which we can use to load modules
only when they are actually installed.

Comment 5 Lennart Poettering 2007-09-07 10:20:41 UTC
The new default config file iin the package I commited to Rawhide today we use
.ifexists to not load modules which are not installed. Thus these warning
messages are no more.


Note You need to log in before you can comment on or make changes to this bug.