Bug 230212 - Beagle crashes on session start
Beagle crashes on session start
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: beagle (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-27 09:54 EST by Bastien Nocera
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-07 05:20:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bastien Nocera 2007-02-27 09:54:56 EST
beagle-0.2.16-1.fc7

** (/usr/lib/beagle/BeagleDaemon.exe:4621): WARNING **: The following assembly
referenced from /usr/lib/beagle/Filters/Filters.dll could not be loaded:
     Assembly:   gsf-sharp    (assemblyref_index=11)
     Version:    0.0.0.7
     Public Key: 35e10195dab3c99f
The assembly was not found in the Global Assembly Cache, a path listed in the
MONO_PATH environment variable, or in the location of the executing assembly
(/usr/lib/beagle/Filters).


** (/usr/lib/beagle/BeagleDaemon.exe:4621): WARNING **: Could not load file or
assembly 'gsf-sharp, Version=0.0.0.7, Culture=neutral,
PublicKeyToken=35e10195dab3c99f' or one of its dependencies.
Stacktrace:

  at (wrapper managed-to-native) System.Array.CreateInstanceImpl
(System.Type,int[],int[]) <0x00004>
  at (wrapper managed-to-native) System.Array.CreateInstanceImpl
(System.Type,int[],int[]) <0xffffffff>
  at System.Array.CreateInstance (System.Type,int[]) <0x0005e>
  at System.Array.CreateInstance (System.Type,int) <0x00043>
  at System.MonoCustomAttrs.GetCustomAttributes
(System.Reflection.ICustomAttributeProvider,System.Type,bool) <0x0054e>
  at System.Reflection.Assembly.GetCustomAttributes (System.Type,bool) <0x00012>
  at System.Attribute.GetCustomAttribute
(System.Reflection.Assembly,System.Type,bool) <0x00024>
  at System.Attribute.GetCustomAttribute
(System.Reflection.Assembly,System.Type) <0x0000f>
  at Beagle.Util.ReflectionFu.GetTypesFromAssemblyAttribute
(System.Reflection.Assembly,System.Type) <0x0004d>
  at Beagle.Daemon.QueryDriver.ReadKeywordMappings () <0x000e3>
  at Beagle.Daemon.QueryDriver.Start () <0x00182>
  at Beagle.Daemon.BeagleDaemon.StartupProcess () <0x00177>
  at (wrapper delegate-invoke) System.MulticastDelegate.invoke_bool () <0xffffffff>
  at IdleProxy.Handler () <0x0002a>
  at (wrapper native-to-managed) IdleProxy.Handler () <0xffffffff>
  at (wrapper managed-to-native) GLib.MainLoop.g_main_loop_run (intptr) <0x00004>
  at (wrapper managed-to-native) GLib.MainLoop.g_main_loop_run (intptr) <0xffffffff>
  at GLib.MainLoop.Run () <0x0000d>
  at Beagle.Daemon.BeagleDaemon.DoMain (string[]) <0x00ad1>
  at Beagle.Daemon.BeagleDaemon.Main (string[]) <0x00014>
  at (wrapper runtime-invoke) System.Object.runtime_invoke_void_string[]
(object,intptr,intptr,intptr) <0xffffffff>

Native stacktrace:

	beagled [0x815110a]
	beagled [0x811a2c8]
	[0x90a440]
	beagled(mono_class_vtable+0x43d) [0x80a4b6d]
	beagled(mono_array_new_full+0x121) [0x80a6951]
	beagled [0x8161aff]
	[0x37642d]
	[0x375757]
	[0x3756ac]
	[0x8f953f]
	[0x8fd4eb]
	[0x8fd4b5]
	[0x8fd478]
	[0x8fd3e6]
	[0xb5db24]
	[0x9c449b]
	[0x9bd600]
	[0x9bd3b6]
	[0x9bd323]
	[0x8ca83af]
	/lib/libglib-2.0.so.0 [0x1396e1]
	/lib/libglib-2.0.so.0(g_main_context_dispatch+0x182) [0x13b442]
	/lib/libglib-2.0.so.0 [0x13e41f]
	/lib/libglib-2.0.so.0(g_main_loop_run+0x1a9) [0x13e7c9]
	[0x9bd2d5]
	[0x9bd28e]
	[0x36b57a]
	[0x36a6c5]
	[0x36a063]
	beagled(mono_runtime_exec_main+0x62) [0x80a7722]
	beagled(mono_runtime_run_main+0x1b9) [0x80a7a09]
	beagled(mono_main+0xeab) [0x805883b]
	beagled [0x8057482]
	/lib/libc.so.6(__libc_start_main+0xe0) [0x3d1ec0]
	beagled [0x80573d1]

Debug info from gdb:

(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 1951456 (LWP 4621)]
[New Thread 29842320 (LWP 4706)]
[New Thread 9096080 (LWP 4623)]
[New Thread 3480464 (LWP 4622)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
0x0090a402 in __kernel_vsyscall ()
  4 Thread 3480464 (LWP 4622)  0x0090a402 in __kernel_vsyscall ()
  3 Thread 9096080 (LWP 4623)  0x0090a402 in __kernel_vsyscall ()
  2 Thread 29842320 (LWP 4706)  0x0090a402 in __kernel_vsyscall ()
  1 Thread 1951456 (LWP 4621)  0x0090a402 in __kernel_vsyscall ()

Thread 4 (Thread 3480464 (LWP 4622)):
#0  0x0090a402 in __kernel_vsyscall ()
#1  0x00dc64a6 in nanosleep () from /lib/libpthread.so.0
#2  0x080f9a24 in ?? ()
#3  0x00dbf2db in start_thread () from /lib/libpthread.so.0
#4  0x00489d3e in clone () from /lib/libc.so.6

Thread 3 (Thread 9096080 (LWP 4623)):
#0  0x0090a402 in __kernel_vsyscall ()
#1  0x00dc30c6 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x080f660f in ?? ()
#3  0x080f8f8f in ?? ()
#4  0x080f900c in ?? ()
#5  0x08105834 in ?? ()
#6  0x080a1c1a in ?? ()
#7  0x080e15d4 in ?? ()
#8  0x080faf22 in ?? ()
#9  0x08115307 in ?? ()
#10 0x00dbf2db in start_thread () from /lib/libpthread.so.0
#11 0x00489d3e in clone () from /lib/libc.so.6

Thread 2 (Thread 29842320 (LWP 4706)):
#0  0x0090a402 in __kernel_vsyscall ()
#1  0x00dc58ce in __lll_mutex_lock_wait () from /lib/libpthread.so.0
#2  0x00dc1734 in _L_mutex_lock_692 () from /lib/libpthread.so.0
#3  0x00dc15f6 in pthread_mutex_lock () from /lib/libpthread.so.0
#4  0x080a1918 in ?? ()
#5  0x080a7ce2 in mono_object_new_alloc_specific ()
#6  0x080a7db8 in mono_object_new_specific ()
#7  0x0036f177 in ?? ()
#8  0x08ca75e4 in ?? ()
#9  0x08ca0ea0 in ?? ()
#10 0x57f9cfc0 in ?? ()
#11 0x0004eeb0 in ?? ()
#12 0x0004eeb0 in ?? ()
#13 0x01c750d0 in ?? ()
#14 0x000ddf60 in ?? ()
#15 0x01c75078 in ?? ()
#16 0x0036f154 in ?? ()
#17 0x01c75100 in ?? ()
#18 0x009f8a87 in ?? ()
#19 0x08ca75e4 in ?? ()
#20 0x009f8938 in ?? ()
#21 0x009f88c8 in ?? ()
#22 0x01c750bc in ?? ()
#23 0x080783d1 in ?? ()
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 1 (Thread 1951456 (LWP 4621)):
#0  0x0090a402 in __kernel_vsyscall ()
#1  0x00482b31 in select () from /lib/libc.so.6
#2  0x00166c3e in g_spawn_sync () from /lib/libglib-2.0.so.0
#3  0x0016700c in g_spawn_command_line_sync () from /lib/libglib-2.0.so.0
#4  0x081511bd in ?? ()
#5  0x0811a2c8 in ?? ()
#6  <signal handler called>
#7  0x080a4b6d in mono_class_vtable ()
#8  0x080a6951 in mono_array_new_full ()
#9  0x08161aff in ?? ()
#10 0x0037642d in ?? ()
#11 0x00ae05d0 in ?? ()
#12 0x00aba9c0 in ?? ()
#13 0x00000000 in ?? ()
#0  0x0090a402 in __kernel_vsyscall ()


=================================================================
Got a SIGSEGV while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries 
used by your application.
=================================================================

Debug: Caught IOException in ReadCallback
Comment 1 Alexander Larsson 2007-03-02 10:05:38 EST
What version of gsf-sharp do you have installed?
Comment 2 William Lovaton 2007-03-04 19:29:08 EST
Hi, I have the exact same problem as Bastien.

I think I managed to get it working, it seems to need the following packages:
- gsf-sharp
- evolution-sharp

Maybe this packages should be dependencies of beagle, right?

It is now indexing my home directory and it hasn't crashed yet... I'll keep you
informed.

Question: How do I force beagle to use all of the resources to index files?
Comment 3 Alexander Larsson 2007-03-07 04:52:02 EST
Those dependencies should have been auto-generated by rpm.
I.e. FC6 has:
mono(gsf-sharp) = 0.0.0.7
Comment 4 Alexander Larsson 2007-03-07 05:06:56 EST
Ok. The auto-requirements generator runs monodis --assemblyref
/usr/lib/beagle/Filters/Filters.dll, and that fails because it can't resolve
BeagleDaemonPlugins in GAC, MONO_PATH or executable path (in this case
/usr/lib/beagle/Filters). However, BeagleDaemonPlugins.dll exists, its just in
/usr/lib/beagle.

Similar things happens to the stuff in /usr/lib/beagle/Backends.

I'm not sure what to do about this. Putting in manual deps seems sort of ugly.
Comment 5 Alexander Larsson 2007-03-07 05:20:46 EST
beagle-0.2.16.2-2.fc7 has the workaround by using manual requirements.
Comment 6 William Lovaton 2007-03-07 07:45:12 EST
Alex,  is this problem related to bugs #230940 and #230960 ??

I think there is a problem with yum or rpm keeping dependencies from being
installed even if the package explicitly say so.
Comment 7 Alexander Larsson 2007-03-08 04:10:21 EST
No, its a pure beagle/mono issue.

Note You need to log in before you can comment on or make changes to this bug.