Bug 230300 - autofs in RHEL 3 Update 8 fail to check the NIS automount map
autofs in RHEL 3 Update 8 fail to check the NIS automount map
Status: CLOSED DUPLICATE of bug 230304
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: autofs (Show other bugs)
3.8
All Linux
medium Severity high
: ---
: ---
Assigned To: Jeffrey Moyer
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-27 21:49 EST by Wesly Chen
Modified: 2007-11-16 20:14 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-05 13:06:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wesly Chen 2007-02-27 21:49:27 EST
Description of problem:
 My Redhat Enterprise Linux WS 3.0 Update 7 upgraded to Update 8, then my 
autofs failed.
It seems to me that the vsion of autofs on update 8. autofs-4.1.3-186, cause 
the problem.
So all my NIS automount maps fail.

   When I start the autofs (# service autofs restart), it shows "Not 
Mountpoints Defined" even though there are a lot of mount points defined in 
NIS. Unless I put those mount points into /etc/auto_<map files>.

   Temporarily work around is roll back the autofs to autofs-4.1.3-168 which 
comes with Update 7.


Version-Release number of selected component (if applicable):
autofs-4.1.3-186

How reproducible:


Steps to Reproduce:
1. install autofs-4.1.3-186
2. create NIS map auto_master with "/home  auto_home" in it
3. Create NIS map auto_home with "user1  <NFS_server>:/users/user1"
4. Make sure <NFS_server>:/users/user1 is shared out on NFS
5. echo "+auto_master" > /etc/auto.master
6. /etc/rc.d/init.d/autofs start
  
Actual results:
# /etc/init.d/autofs start
Starting automount: No Mountpoints Defined    [  OK  ]

Expected results:
# /etc/init.d/autofs start
Starting automount:        [  OK  ]

Additional info:
1.
$ grep -v ^# /etc/sysconfig/autofs
LOCALOPTIONS=""
DAEMONOPTIONS="--timeout=60"
LDAPAUTOMASTER=""
UNDERSCORETODOT=1
DISABLE_DIRECT=1
ONE_AUTO_MASTER=0
GHOSTDIRS=""
BASEDN=

2.
$ grep automount /etc/nsswitch.conf
automount:  files nis

3. 
$ grep -v ^# /etc/auto.master
+auto_master

4. 
$ ypcat -k auto_master
/user auto_home

5.
$ ypcat -k auto_home
*  <NFS server name>:/vol/fvol1/users/&

6.
$ uname -r
2.4.21-47.0.1.ELsmp

7. 
$cat /etc/redhat-release 
Red Hat Enterprise Linux WS release 3 (Taroon Update 8)
Comment 1 Jeffrey Moyer 2007-03-05 13:06:28 EST

*** This bug has been marked as a duplicate of 230304 ***

Note You need to log in before you can comment on or make changes to this bug.