Bug 23040 - unresolved symbol
unresolved symbol
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
6.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-30 19:58 EST by TARogue
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-30 19:58:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description TARogue 2000-12-30 19:58:39 EST
I installed kde*2.0.1, with all relevant libraries as found at SourceForge.
When I try to actually RUN it, I get:

ksplash: error in loading shared libraries: /usr/lib/libkdeui.so.3:
undefined symbol: minimumSizeHint__C7QDialog
kdeinit: error in loading shared libraries: /usr/lib/libkdecore.so.3:
undefined symbol: startsWith__C7QStringRC7QString
knotify: error in loading shared libraries: /usr/lib/libkdeui.so.3:
undefined symbol: minimumSizeHint__C7QDialog
ktip: error in loading shared libraries: /usr/lib/libkdeui.so.3: undefined
symbol: event__9QLineEditP6QEvent
Session management error: networkIdsList argument is NULL
ksmserver: error in loading shared libraries: /usr/lib/libkdecore.so.3:
undefined symbol: new_metaaccess__11QMetaObjecti

Using 'objdump -T /usr/bin/ksplash | less' i found that
minimumSizeHint__C7QDialog isn't even there! The same is true of all the
above listed symbols, from kdebase-2.0.1-1, kdelibs-2.0.1-1, and
kdelibs-sound-2.0.1-1
Comment 1 Bernhard Rosenkraenzer 2001-01-01 06:25:07 EST
This looks like you aren't using the right version of Qt.
Make sure you're using Qt >= 2.2.2.

Note You need to log in before you can comment on or make changes to this bug.