Bug 230411 - gnome-settings-daemon does not start
gnome-settings-daemon does not start
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-28 14:20 EST by Bill Nottingham
Modified: 2014-03-16 23:05 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-12 08:41:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2007-02-28 14:20:20 EST
Description of problem:

On login, I get:

There was an error starting the GNOME Settings Daemon.

Some things, such as themes, sounds, or background settings may not work correctly.

The last error message was:

An SELinux policy prevents this sender from sending this message to this
recipient (rejected message had interface "org.freedesktop.DBus" member "Hello"
error name "(unset)" destination "org.freedesktop.DBus")

GNOME will still try to restart the Settings Daemon next time you log in.

Version-Release number of selected component (if applicable):

selinux-policy-targted-2.5.5-2.fc6
dbus-1.0.1-3.fc7
control-center-2.17.92-1.fc7

How reproducible:

Every time.

Steps to Reproduce:
1. Log in as root.
2. Yeah, I said 'root', go ahead and shoot me.
  
Additional info:

The error message needs a 'the' before 'next time'.
Comment 1 Daniel Walsh 2007-02-28 15:46:46 EST
Avc Messages?
Comment 2 Bill Nottingham 2007-02-28 15:53:35 EST
type=AVC msg=audit(1172710334.367:28): avc:  denied  { getattr } for  pid=2027
comm="mcstransd" name="/" dev=selinuxfs ino=525
scontext=system_u:system_r:setrans_t:s0-s0:c0.c1023
tcontext=system_u:object_r:security_t:s0 tclass=filesystem
type=AVC msg=audit(1172710336.090:29): avc:  denied  { getattr } for  pid=2070
comm="setroubleshootd" name="/" dev=selinuxfs ino=525
scontext=system_u:system_r:setroubleshootd_t:s0
tcontext=system_u:object_r:security_t:s0 tclass=filesystem
type=AVC msg=audit(1172710337.294:30): avc:  denied  { getattr } for  pid=2134
comm="mount" name="/" dev=selinuxfs ino=525
scontext=system_u:system_r:mount_t:s0 tcontext=system_u:object_r:security_t:s0
tclass=filesystem
type=AVC msg=audit(1172710339.904:31): avc:  denied  { getattr } for  pid=2239
comm="mount" name="/" dev=selinuxfs ino=525
scontext=system_u:system_r:mount_t:s0 tcontext=system_u:object_r:security_t:s0
tclass=filesystem
type=AVC msg=audit(1172710339.999:32): avc:  denied  { execute_no_trans } for 
pid=2240 comm="hcid" name="bluetoothd-service-input" dev=dm-0 ino=10118669
scontext=system_u:system_r:bluetooth_t:s0 tcontext=system_u:object_r:lib_t:s0
tclass=file
type=AVC_PATH msg=audit(1172710339.999:32): 
path="/usr/lib64/bluetooth/bluetoothd-service-input"
type=AVC msg=audit(1172710341.416:33): avc:  denied  { getattr } for  pid=2310
comm="mount" name="/" dev=selinuxfs ino=525
scontext=system_u:system_r:mount_t:s0 tcontext=system_u:object_r:security_t:s0
tclass=filesystem
type=AVC msg=audit(1172710341.420:34): avc:  denied  { getattr } for  pid=2311
comm="umount" name="/" dev=selinuxfs ino=525
scontext=system_u:system_r:mount_t:s0 tcontext=system_u:object_r:security_t:s0
tclass=filesystem
type=AVC msg=audit(1172713903.853:19): avc:  denied  { getattr } for  pid=2094
comm="mcstransd" name="/" dev=selinuxfs ino=525
scontext=system_u:system_r:setrans_t:s0-s0:c0.c1023
tcontext=system_u:object_r:security_t:s0 tclass=filesystem
type=AVC msg=audit(1172713904.694:20): avc:  denied  { getattr } for  pid=2136
comm="setroubleshootd" name="/" dev=selinuxfs ino=525
scontext=system_u:system_r:setroubleshootd_t:s0
tcontext=system_u:object_r:security_t:s0 tclass=filesystem
type=AVC msg=audit(1172713904.709:21): avc:  denied  { getattr } for  pid=2200
comm="mount" name="/" dev=selinuxfs ino=525
scontext=system_u:system_r:mount_t:s0 tcontext=system_u:object_r:security_t:s0
tclass=filesystem
type=AVC msg=audit(1172713904.709:22): avc:  denied  { search } for  pid=2201
comm="arping" name="/" dev=sysfs ino=1 scontext=system_u:system_r:netutils_t:s0
tcontext=system_u:object_r:sysfs_t:s0 tclass=dir
type=AVC msg=audit(1172713904.709:22): avc:  denied  { getattr } for  pid=2201
comm="arping" name="eth0" dev=sysfs ino=5421
scontext=system_u:system_r:netutils_t:s0 tcontext=system_u:object_r:sysfs_t:s0
tclass=dir
type=AVC_PATH msg=audit(1172713904.709:22):  path="/sys/class/net/eth0"
type=AVC msg=audit(1172713904.709:23): avc:  denied  { getattr } for  pid=2201
comm="arping" name="broadcast" dev=sysfs ino=8315
scontext=system_u:system_r:netutils_t:s0 tcontext=system_u:object_r:sysfs_t:s0
tclass=file
type=AVC_PATH msg=audit(1172713904.709:23):  path="/sys/class/net/eth0/broadcast"
type=AVC msg=audit(1172713904.710:24): avc:  denied  { read } for  pid=2201
comm="arping" name="broadcast" dev=sysfs ino=8315
scontext=system_u:system_r:netutils_t:s0 tcontext=system_u:object_r:sysfs_t:s0
tclass=file
type=AVC msg=audit(1172713915.662:25): avc:  denied  { execute_no_trans } for 
pid=2297 comm="hcid" name="bluetoothd-service-input" dev=dm-0 ino=10118669
scontext=system_u:system_r:bluetooth_t:s0 tcontext=system_u:object_r:lib_t:s0
tclass=file
type=AVC_PATH msg=audit(1172713915.662:25): 
path="/usr/lib64/bluetooth/bluetoothd-service-input"
type=AVC msg=audit(1172713915.707:26): avc:  denied  { getattr } for  pid=2316
comm="mount" name="/" dev=selinuxfs ino=525
scontext=system_u:system_r:mount_t:s0 tcontext=system_u:object_r:security_t:s0
tclass=filesystem
type=AVC msg=audit(1172713943.930:35): avc:  denied  { execheap } for  pid=3012
comm="beagle-search" scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023
tcontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tclass=process
Comment 3 Daniel Walsh 2007-03-01 09:41:31 EST
selinux-policy-2.5.6-1 should have fixed all of these avc messages.  A couple of
problems I see though are beagle-search running as xdm_t, this looks like you
did not transition properly on login?  
Comment 4 Bill Nottingham 2007-03-01 11:34:28 EST
Still happens with 2.5.6-1. No relevant AVCs, afaict.
Comment 5 Daniel Walsh 2007-03-12 08:41:15 EDT
This is fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.