Bug 230484 - MAJOR BUG: fs/dquot.c:422! kernel panicing
MAJOR BUG: fs/dquot.c:422! kernel panicing
Status: CLOSED DUPLICATE of bug 209639
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.4
All Linux
medium Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-28 17:52 EST by Diego H. Fernández del Prado
Modified: 2007-11-16 20:14 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-12 13:36:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of the kernel panic (197.64 KB, image/jpeg)
2007-02-28 17:52 EST, Diego H. Fernández del Prado
no flags Details

  None (edit)
Description Diego H. Fernández del Prado 2007-02-28 17:52:28 EST
>>> This is a major bug problem that must be fixed soon <<<

We are using CentOs kernel 2.6.9-42.0.10ELsmp and still this terrible bug 
hadnt been fixed. We read that there is a testing kernel that fix this issue 
----
Fix BUG() check in invalidate_dquots() (David Milburn) [209639]
In kernel 2.6.9-42.22

Is not a possible way to extract the line of code that fix the issue and apply 
it to the kernel and make it public??
To give it a try in the next 2.6.9-42.0.xx public update for example!

It´s happening with high IO States when transfering accounts from server to 
server or when user modify quotas in high io states.
In very busy servers is not good to be rebooting the server more than 4 times 
in the day!

I hope you take care seriously of this bug as soon as possible.

Nov 27 14:58:35 newinst kernel: ------------[ cut here ]------------
Nov 27 14:58:35 newinst kernel: kernel BUG at fs/dquot.c:422!
Nov 27 14:58:35 newinst kernel: invalid operand: 0000 [0000001]
Nov 27 14:58:35 newinst kernel: SMP
Nov 27 14:58:35 newinst kernel: Modules linked in: iptable_mangle 
ip_conntrack_ftp ipt_conntrack ipt_REJECT ipt_LOG ipt_limi$
Nov 27 14:58:35 newinst kernel: CPU: 1
Nov 27 14:58:35 newinst kernel: EIP: 0060:[<c01823db>] Not tainted VLI
Nov 27 14:58:35 newinst kernel: EFLAGS: 00010202 (2.6.9-42.0.3.ELsmp)
Nov 27 14:58:35 newinst kernel: EIP is at invalidate_dquots+0x3d/0xc3
Nov 27 14:58:35 newinst kernel: eax: 00000001 ebx: dbc470e0 ecx: dbc47900 edx: 
00000000
Nov 27 14:58:35 newinst kernel: esi: dbc47058 edi: 00000000 ebp: f7f40400 esp: 
f3da2eec
Nov 27 14:58:35 newinst kernel: ds: 007b es: 007b ss: 0068
Nov 27 14:58:35 newinst kernel: Process quotaoff (pid: 20240, 
threadinfo=f3da2000 task=ee2a82b0)
Nov 27 14:58:35 newinst kernel: Stack: f7f404ac f7f404ac f7f40400 00000000 
c0183b80 00000000 00000000 f7f40400
Nov 27 14:58:35 newinst kernel: 00000000 00800003 c0185d1e 00000000 c0166267 
80000300 f7154580 f3da2000
Nov 27 14:58:35 newinst kernel: f70e5214 fffffff4 c016f070 f3da2f50 fffffff4 
00000000 c0166484 f7f53080
Nov 27 14:58:35 newinst kernel: Call Trace:
Nov 27 14:58:35 newinst kernel: [<c0183b80>] vfs_quota_off+0x92/0x115
Nov 27 14:58:35 newinst kernel: [<c0185d1e>] do_quotactl+0x10d/0x4aa
Nov 27 14:58:35 newinst kernel: [<c0166267>] getname+0x5b/0xb2
Nov 27 14:58:35 newinst kernel: [<c016f070>] dput+0x34/0x1a7
Nov 27 14:58:35 newinst kernel: [<c0166484>] path_release+0xa/0x2d
Nov 27 14:58:35 newinst kernel: [<c016215b>] lookup_bdev+0x66/0x74
Nov 27 14:58:35 newinst kernel: [<c02d2d76>] __cond_resched+0x14/0x39
Nov 27 14:58:35 newinst kernel: [<c01a7c31>] capable+0x15/0x2c
Nov 27 14:58:35 newinst kernel: [<c0185ae9>] check_quotactl_valid+0x231/0x23b
Nov 27 14:58:35 newinst kernel: [<c018617c>] sys_quotactl+0xc1/0xd8
Nov 27 14:58:35 newinst kernel: [<c02d47cb>] syscall_call+0x7/0xb
Nov 27 14:58:35 newinst kernel: Code: 8b 35 b4 e6 32 c0 81 fe b4 e6 32 c0 0f 
84 91 00 00 00 8d 5e f8 8b 36 39 6b 4c 75 ea 0f$
Nov 27 14:58:35 newinst kernel: <0>Fatal exception: panic in 5 seconds
Comment 1 Diego H. Fernández del Prado 2007-02-28 17:52:29 EST
Created attachment 148970 [details]
Screenshot of the kernel panic
Comment 2 Jason Baron 2007-03-12 13:36:03 EDT

*** This bug has been marked as a duplicate of 209639 ***

Note You need to log in before you can comment on or make changes to this bug.