Bug 230488 - pm-utils: /etc/pm/functions breaks if a global config variable contains more than one element
pm-utils: /etc/pm/functions breaks if a global config variable contains more ...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pm-utils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-28 18:17 EST by Michel Alexandre Salim
Modified: 2015-03-04 20:18 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-19 18:07:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michel Alexandre Salim 2007-02-28 18:17:45 EST
Description of problem:
I have an Atheros-based network card that needs to be unloaded before
suspending, and created a /etc/pm/config.d/wlan containing:

SUSPEND_MODULES+=" ath_pci"

This, however, breaks /etc/pm/functions at line 29, and the module does not get
unloaded/reloaded on suspend.

Version-Release number of selected component (if applicable):
0.19.1-6.fc7

How reproducible:
Always

Steps to Reproduce:
1. Create a file in /etc/pm/config.d that adds something to, e.g., SUSPEND_MODULES
2. . /etc/pm/functions
  
Actual results:
/etc/pm/functions: line 29: ath_pci: command not found


Expected results:
It should just work


Additional info:
Comment 1 Michel Alexandre Salim 2007-03-01 14:16:55 EST
Note: it's not the content of SUSPEND_MODULES that's causing the problem, it's
the parsing of files in /etc/pm/config.d -- after commenting out the line in
/etc/pm/config.d/wlan I get other errors, but if I modify /etc/pm/config so the
SUSPEND_MODULES line is

SUSPEND_MODULES="button ath_pci"

everything works.
Comment 2 Till Maas 2007-09-19 18:07:16 EDT
This is fixed in pm-utils 0.99.4-2.fc8

Note You need to log in before you can comment on or make changes to this bug.