Bug 23050 - netscape launch yields bus error for all but root
netscape launch yields bus error for all but root
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: netscape (Show other bugs)
6.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-30 22:55 EST by Need Real Name
Modified: 2014-03-16 22:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-19 22:24:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-12-30 22:55:40 EST
If any user, other than root, launches netscape, then a "Bus error" ensues
before a netscape window opens.  Removal of .netscape/ directory has no
effect.  Created a new user account and attempted netscape launch as this
user (both via login and 'su') again with identical results.

Began with a RH6.2 + old (Sept) errata-updated system; i386 (i686); kernel
2.2.14-5.0; GNOME + Enlightenment.
Installed new versions of 'rpm' and 'up2date' via errata instructions. 
Then upgraded other system componenets using the new 'up2date' agent,
including netscape and glibc.  The complete list of upgraded rpm's is given
below.

Installation of older versions of netscape does not correct the problem. 
Root continues to be the only user who may launch netscape without
receiving a bus error.


Upgraded package list:

netscape-navigator-4.76-0.6.2
netscape-communicator-4.76-0.6.2
netscape-common-4.76-0.6.2
xwpick-2.20-12
xdosemu-0.99.13-6
traceroute-1.4a5-24.6x
sysklogd-1.3.31-17
php-manual-3.0.17-1.6.2
php-imap-3.0.17-1.6.2
php-3.0.17-1.6.2
ncurses-devel-5.0-12
ncurses-5.0-12
mxp-1.0-12
modutils-2.3.21-0.6.2
imap-2000-2.6
gpm-1.19.3-0.6.x
glibc-profile-2.1.3-21
glibc-devel-2.1.3-21
glibc-2.1.3-21
xpdf-0.91-1.6x
xearth-1.1-1
xanim-2.80.1-7
tmpwatch-2.6.2-1.6.2
tcsh-6.10-0.6.x
lpr-0.50-7.6.x
iputils-20001010-1.6x
ghostscript-5.50-8_6.x
esound-0.2.20-0
emacs-nox-20.7-1
emacs-el-20.7-1
ed-0.2-19.6x
bash-1.14.7-23.6x
up2date-gnome-2.1.7-0.6.x
up2date-2.1.7-0.6.x
rhn_register-gnome-1.0.2-0.6.x
rhn_register-1.0.2-0.6.x
python-xmlrpc-1.2.1-0.6.x
python-1.5.2-27.6.x
openssl-0.9.5a-2.6.x
gnupg-1.0.4-8.6.x
gnorpm-0.95.1-5.6x
usermode-1.37-1.6
rpm-python-3.0.5-9.6x
rpm-devel-3.0.5-9.6x
rpm-build-3.0.5-9.6x
popt-1.5-9.6x
Comment 1 Bryce Nesbitt 2001-01-08 09:30:19 EST
To debug this:

Try "gdb".  Do "which netscape",and look at the wrapper script to determine
which netscape binary is run.  Then use something like "gdb
/usr/lib/netscape/netscape-communicator ", and type "run".

Now when it crashes do "bt" (backtrace).
Comment 2 Bill Nottingham 2001-01-19 16:53:40 EST
I've tried this here, and I can't reproduce it; netscape in a standard
install works for both normal users and for root.
Comment 3 Need Real Name 2001-01-19 22:24:37 EST
Reinstalled RH6.2 and updated packages piecemeal, checking for point at which
netscape fails.
(Did this before receiving bryce's suggestion.)
It never did happen, so I wasn't able to reproduce the behavior, either.  Not
that I'm complaining...

Note You need to log in before you can comment on or make changes to this bug.