Description of problem:
Since the release of Autoconf 2.59, a number of portability related problems
have been fixed in Autoconf. Distributing a configure infrastructure made using
Autoconf 2.59 is telling the user to solve these portability issues themselves.
Moreover as a developer of GNU Parted I have to use 2.61 instead of anything
older since Parted's configure scripts are generated using Autoconf 2.61
because we would not like our users to face any problem.
Version-Release number of selected component (if applicable):
From this link: http://www.gnu.org/software/autoconf/#TOCintroduction it seems
that GNU M4 1.7 or later would be a dependency. Currently Fedora has GNU 1.4.5.
adding the m4 maintainer for comments about the m4 update...
Vitezslav, is a m4 update possible without breaking anything ?
First of all sorry for saying "that GNU M4 1.7 or later would be a dependency".
It should be version 1.4.7. I have been using GNU M4 1.4.8 compiled from source
for the last few dayss, and am yet to notice any breakage.
updating m4 seems OK to me and I'll update it.
M4 updated to 1.4.8 in FC-6.
(In reply to comment #4)
> M4 updated to 1.4.8 in FC-6.
I don't see any m4 versions >= 1.4.5 for FC-6 in updates or updates-testing.
Was this meant to say FC-7?
Sorry, I only built it and forgot add update... Thanks for giving a notice!
Since Rawhide already has Autoconf 2.61, can this bug be closed?