This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 230601 - Feature Request: Autoconf 2.61
Feature Request: Autoconf 2.61
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: autoconf (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-01 13:34 EST by Debarshi Ray
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.61-9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-14 02:19:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Debarshi Ray 2007-03-01 13:34:12 EST
Description of problem:

Since the release of Autoconf 2.59, a number of portability  related problems
have been fixed in Autoconf. Distributing a configure infrastructure made using
Autoconf 2.59 is telling the user to solve these portability issues themselves.
Moreover as a developer of GNU Parted I have to use 2.61 instead of anything
older since  Parted's configure scripts are generated using Autoconf 2.61
because we would not like our users to face any problem.


Version-Release number of selected component (if applicable):

Autoconf 2.59.


Additional info:

From this link: http://www.gnu.org/software/autoconf/#TOCintroduction it seems
that GNU M4 1.7 or later would be a dependency. Currently Fedora has  GNU 1.4.5.
Comment 1 Karsten Hopp 2007-03-02 07:56:10 EST
adding the m4 maintainer for comments about the m4 update...

Vitezslav, is a m4 update possible without breaking anything ?
Comment 2 Debarshi Ray 2007-03-07 04:22:33 EST
First of all sorry for saying "that GNU M4 1.7 or later would be a dependency".
It should  be version 1.4.7. I have been using GNU M4 1.4.8 compiled from source
for the last few dayss, and am yet to notice any breakage.
Comment 3 Vitezslav Crhonek 2007-03-20 08:39:45 EDT
Hello,
updating m4 seems OK to me and I'll update it.
Comment 4 Vitezslav Crhonek 2007-03-21 04:17:31 EDT
M4 updated to 1.4.8 in FC-6.
Comment 5 Ville Skyttä 2007-04-11 15:49:22 EDT
(In reply to comment #4)
> M4 updated to 1.4.8 in FC-6.

I don't see any m4 versions >= 1.4.5 for FC-6 in updates or updates-testing. 
Was this meant to say FC-7?
Comment 6 Vitezslav Crhonek 2007-04-16 11:16:51 EDT
Sorry, I only built it and forgot add update... Thanks for giving a notice!
Comment 7 Debarshi Ray 2007-05-19 00:15:05 EDT
Since Rawhide already has Autoconf 2.61, can this bug be closed?  

Note You need to log in before you can comment on or make changes to this bug.