Bug 230631 - Multilib conflict (upgrade path): /usr/share/man/man1/esd.1.gz
Multilib conflict (upgrade path): /usr/share/man/man1/esd.1.gz
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: esound (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bastien Nocera
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-01 16:32 EST by Saikat Guha
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 1:0.2.38-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-08 10:11:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Saikat Guha 2007-03-01 16:32:42 EST
file /usr/share/man/man1/esd.1.gz from install of esound-0.2.37-1.fc7 conflicts
with file from package esound-0.2.36-3

See Bug #229992 for a similar multilib problem with device-mapper.



[root@sioux ~]# rpm -q esound
esound-0.2.36-3.i386
esound-0.2.36-5.fc7.x86_64
[root@sioux ~]# yum --noplugins upgrade esound
Setting up Upgrade Process
Setting up repositories
Reading repository metadata in from local files
Resolving Dependencies
--> Running transaction check
Checking deps for esound.x86_64 1-0.2.37-1.fc7 - u
Checking deps for esound.x86_64 1-0.2.36-5.fc7 - None

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Updating:
 esound                  x86_64     1:0.2.37-1.fc7   development        73 k

Transaction Summary
=============================================================================
Install      0 Package(s)
Update       1 Package(s)
Remove       0 Package(s)

Total download size: 73 k
Is this ok [y/N]: y
Downloading Packages:
Running Transaction Test
Finished Transaction Test


Transaction Check Error:
  file /usr/share/man/man1/esd.1.gz from install of esound-0.2.37-1.fc7
conflicts with file from package esound-0.2.36-3
Comment 1 Saikat Guha 2007-03-01 16:33:56 EST
Also the following files:


file /etc/esd.conf from install of esound-libs-0.2.37-1.fc7 conflicts with file
from package esound-0.2.36-3

file /usr/share/man/man1/esd-config.1.gz from install of
esound-devel-0.2.37-1.fc7 conflicts with file from package esound-0.2.36-3
Comment 2 Bastien Nocera 2007-03-01 18:25:48 EST
What's the output of:
rpm -q --qf "%{name}-%{version}-%{release}.%{arch}\n" esound-devel
?
Comment 3 Saikat Guha 2007-03-01 18:31:35 EST
[root@sioux ~]# rpm -q --qf "%{name}-%{version}-%{release}.%{arch}\n" esound-devel
esound-devel-0.2.36-5.fc7.x86_64
Comment 4 Bastien Nocera 2007-03-01 18:38:09 EST
Missing a few obsoletes I guess...
Comment 5 Bastien Nocera 2007-05-08 10:11:25 EDT
Should be fixed in esound-1:0.2.38-1.fc7
Comment 6 Richard Schwarting 2007-05-16 02:16:14 EDT
I just installed Fedora 7 Test 4 and ran a yum upgrade, and I still get a
conflict with this package.  My FC6 install was fairly recent (a couple weeks
ago), and I don't think I did anything to mangle the state of esound.  

What I've just tried is removing the existing esound with "rpm -e --nodeps", as
30 GNOME packages feel that they can't live without it elsewise, and force
installing the new one from an RPM.  yum seems to be letting me do an upgrade
now, though I won't know if I broke anything until I restart GNOME, I guess :|

I'll reply again if this doesn't fix me :)

Note You need to log in before you can comment on or make changes to this bug.