Bug 230656 - no sound recording
no sound recording
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
All Linux
high Severity medium
: ---
: ---
Assigned To: Martin Stransky
Depends On:
  Show dependency treegraph
Reported: 2007-03-01 17:44 EST by Marius Andreiana
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-08-15 12:18:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
lspci -vvv (16.66 KB, text/plain)
2007-03-01 17:44 EST, Marius Andreiana
no flags Details
scsconfig.log (47.64 KB, text/plain)
2007-03-07 02:34 EST, Marius Andreiana
no flags Details
scsconfig.log (51.76 KB, text/plain)
2007-03-08 18:51 EST, Kurt Heine
no flags Details
scsrun.log log file (134 bytes, text/plain)
2007-03-08 18:52 EST, Kurt Heine
no flags Details

  None (edit)
Description Marius Andreiana 2007-03-01 17:44:34 EST
With F7t2 - no sound recording (tested audacity, skype). They lock/skip it

Linux localhost 2.6.20-1.2932.fc7 #1 SMP Thu Feb 15 11:02:47 EST 2007 i686 i686
i386 GNU/Linux
Comment 1 Marius Andreiana 2007-03-01 17:44:34 EST
Created attachment 149062 [details]
lspci -vvv
Comment 2 Martin Stransky 2007-03-06 12:24:05 EST
can you please attach /root/scsconfig.log? it can be generated by
Comment 3 Marius Andreiana 2007-03-07 02:34:50 EST
Created attachment 149436 [details]

Comment 4 Kurt Heine 2007-03-08 18:49:03 EST
I am trying to use a sound applcation (xmms/noatun/rhythmbox/etc) and I find
that I am getting no sound.  I have checked all the sound channels and un-muted
them and turned them onto full volume and still no go.  I have even download an
ogg file and tried to run it from the command line using ogg123 and still no go.
 Interesting thing is if I run ogg123 with the '-d oss' it all seems to work
fine.  I get the following output from ogg123 :
[k@localhost Desktop]$ ogg123 -v noa_061222_053.ogg 

Audio Device:   Advanced Linux Sound Architecture (ALSA) output
Author:   Bill Currie <bill@taniwha.org>/Kevin Cody, Jr. <kevinc@wuff.dhs.org>
Comments: Outputs to the Advanced Linux Sound Architecture version 0.9.x.

Playing: noa_061222_053.ogg
Ogg Vorbis stream: 1 channel, 44100 Hz
Vorbis format: Version 0
Bitrate hints: upper=0 nominal=96000 lower=0 window=0
Encoded by: Xiph.Org libVorbis I 20040629
ALSA snd_pcm_hw_params_set_channels error: Invalid argument
Error: Cannot open device alsa09.

Segmentation fault

Running the system-config-soundcard I can get the tune to play without any problems.

I have included my scsconfig.log log file.

- Kurt
Comment 5 Kurt Heine 2007-03-08 18:51:21 EST
Created attachment 149659 [details]

scsconfig.log log file
Comment 6 Kurt Heine 2007-03-08 18:52:07 EST
Created attachment 149660 [details]
scsrun.log log file

scsrun.log log file
Comment 7 Martin von Weissenberg 2007-04-02 08:31:02 EDT
Hello guys,

I have the same problem as the OP on almost identical hardware (Dell Latitude
D820). Running FC6 with ATRPMs, dries and Livna.

By adding 'options snd-hda-intel model=3stack' to
/etc/modprobe.d/sound.localhost, rebooting and fiddling around with alsamixer, I
was able to record sound with Skype Test Call exactly once. After that, the
microphone is totally mute again.

Sound playback has been working fine from day one. I'm mostly using gstreamer.


I'm going to recompile the FC7 SRPMS for alsa and see what happens.

Comment 8 Martin Stransky 2007-06-26 11:08:57 EDT
new drivers are at http://people.redhat.com/stransky/alsa/
Comment 9 Marius Andreiana 2007-07-08 07:19:53 EDT
WIth current updates, it works for me.
Martin vW, let's close if it's ok for you too.
Comment 10 Martin Stransky 2007-07-09 04:13:14 EDT
okay. what packages/kernel work for you?
Comment 11 Marius Andreiana 2007-07-09 05:23:34 EDT
# rpm -qa|grep alsa
(weird, there are 2 alsa-utils)

Comment 12 Martin Stransky 2007-08-15 12:18:43 EDT
okay, closing.

Note You need to log in before you can comment on or make changes to this bug.