Bug 230725 - package manager crashes on startup after install of yum components
package manager crashes on startup after install of yum components
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-02 10:05 EST by Mark Shiffer
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-10 12:00:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
saved dump from program (1.41 KB, text/plain)
2007-03-02 10:05 EST, Mark Shiffer
no flags Details

  None (edit)
Description Mark Shiffer 2007-03-02 10:05:50 EST
Description of problem:
After installing yum-versionlock component, package manager crashed on startup
with error message:  Unhandled Exception.  It is a file not found error.



Version-Release number of selected component (if applicable):


How reproducible:
Completely reliably


Steps to Reproduce:
1.Manually create missing file (/etc/yum/pluginconf.d/versionlock.list)
2.Uninstall yum-versionlock package
3.Manually delete missing file
4.Reinstall yum-versionlock package
5.Start Package Manager
  
Actual results:
Package Manger crashes

Expected results:
Package Manager runs

Additional info:

This may be considered both a Package Manager and/or yum-versionlock problem. 
Package Manager should catch the exception and handle it...  maybe
yum-versionlock should be creating the proper file on startup.  There is a file
'versionlock.conf'.  Not sure if that is the file the Package Manager should be
looking for instead of 'versionlock.list'.
Comment 1 Mark Shiffer 2007-03-02 10:05:50 EST
Created attachment 149122 [details]
saved dump from program
Comment 2 Tim Lauridsen 2007-04-10 12:00:48 EDT
I the latest version of yum-utils the versionlock plugin is disabled by default.
It is by design it fails when the versionlock if it is enabled and no file exists.
If you enable the versionlock plugin by edit the plugin conf file you have to
create a versionlock file.
Comment 3 Mark Shiffer 2007-04-13 20:08:44 EDT
(In reply to comment #2)
> I the latest version of yum-utils the versionlock plugin is disabled by default.
> It is by design it fails when the versionlock if it is enabled and no file exists.
> If you enable the versionlock plugin by edit the plugin conf file you have to
> create a versionlock file.

I'm going to recap what you said to make sure I understand what you said, and
then disagree with what it is I think you said.

"The latest version of yum-utils is disabled by default."  I'm ok with that.

"It is by design that it fails when the file isn't there."  I'm not ok with
that.  How is an unhandled exception a designed failure?  Since when is it a
design to crash when something you're looking for isn't there?

"If you enable the versionlock plugin by editing the plugin configuration file,
you must create the versionlock file."  I'm ok with that, except I ditn' turn on
the plugin by editing anything.  I turned it on through the
Applications->Add/Remove Software frontend to yum.  If I do that, it doesn't
strike me as user friendly that I have to then add the file or not be able to
use my front end to yum anymore.

And my final comment/question is what do you gain by forcing the user to create
a blank file when they add that component anyway?
Comment 4 Tim Lauridsen 2007-04-15 01:34:54 EDT
(In reply to comment #3)
> "It is by design that it fails when the file isn't there."  I'm not ok with
> that.  How is an unhandled exception a designed failure?  Since when is it a
> design to crash when something you're looking for isn't there?
> 
In the latest version, it is just quiting with a message.
The author want it to break if the file is missing.
Take this this example.
One a production system it is vital that a special application is kept on
specific version, but the rest should be updated as normal.
versionlock is activated and the versionlock file is created.

1. by some error the versionlock file is deleted.
it this situation the plugin is design to make yum fail, so it detected there is
 some thing rotten on the system.



> "If you enable the versionlock plugin by editing the plugin configuration file,
> you must create the versionlock file."  I'm ok with that, except I ditn' turn on
> the plugin by editing anything.  I turned it on through the
> Applications->Add/Remove Software frontend to yum.  If I do that, it doesn't
> strike me as user friendly that I have to then add the file or not be able to
> use my front end to yum anymore.
> 
in the latest versions of yum-utils (1.0.x for yum-3.0.x (FC6) & yum-utils 1.1.x
for yum 3.1 (FC7), the plugin is not enabled by default, you have to first
install it and the edit the /etc/yum/pluginconf.d/versionlock.conf and set
enabled=1 and create a versionlock file to make it work.
By make i disabled by installation, it avoid situations where people have
installed the plugin without wanting to use it.





Note You need to log in before you can comment on or make changes to this bug.