Bug 230771 - yum - Error: Package tuple ... could not be found in packagesack
Summary: yum - Error: Package tuple ... could not be found in packagesack
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: yum   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-02 19:31 UTC by Michal Jaegermann
Modified: 2014-01-21 22:57 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-02 20:39:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michal Jaegermann 2007-03-02 19:31:40 UTC
Description of problem:

After an update to yum-3.1.3-1.fc7 an attempt to run yum as
follows:

   yum --exclude='openoff*' update

ends up with:
....
Excluding Packages in global exclude list
Finished
Error: Package tuple (u'openoffice.org-core', u'x86_64', u'1', u'2.2.0', u'9.1')
could not be found in packagesack

An attempt to clean metadata and to start again does not help.
Backing off an update to yum-3.1.2-1.fc7 resolves the issue immediately.

Version-Release number of selected component (if applicable):
yum-3.1.3-1.fc7

How reproducible:
It looks like always.

Comment 1 Jeremy Katz 2007-03-02 20:39:58 UTC
Fixed in upstream CVS.  Will probably build a package with a roll-up of fixes
from upstream later this afternoon.


Note You need to log in before you can comment on or make changes to this bug.