Bug 230771 - yum - Error: Package tuple ... could not be found in packagesack
yum - Error: Package tuple ... could not be found in packagesack
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Depends On:
  Show dependency treegraph
Reported: 2007-03-02 14:31 EST by Michal Jaegermann
Modified: 2014-01-21 17:57 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-03-02 15:39:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2007-03-02 14:31:40 EST
Description of problem:

After an update to yum-3.1.3-1.fc7 an attempt to run yum as

   yum --exclude='openoff*' update

ends up with:
Excluding Packages in global exclude list
Error: Package tuple (u'openoffice.org-core', u'x86_64', u'1', u'2.2.0', u'9.1')
could not be found in packagesack

An attempt to clean metadata and to start again does not help.
Backing off an update to yum-3.1.2-1.fc7 resolves the issue immediately.

Version-Release number of selected component (if applicable):

How reproducible:
It looks like always.
Comment 1 Jeremy Katz 2007-03-02 15:39:58 EST
Fixed in upstream CVS.  Will probably build a package with a roll-up of fixes
from upstream later this afternoon.

Note You need to log in before you can comment on or make changes to this bug.