Bug 230792 - Xorg i810 signal 11 backtrace
Xorg i810 signal 11 backtrace
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
6
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Adam Jackson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-02 16:42 EST by Zachary Whitley
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 1.1.47-7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-04 12:07:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Zachary Whitley 2007-03-02 16:42:24 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.10) Gecko/20070226 Fedora/1.5.0.10-1.fc6 Firefox/1.5.0.10 pango-text

Description of problem:
Xorg fails to start.

Xorg.0.log

(==) Mouse0: Emulate3Buttons, Emulate3Timeout: 50
(**) Option "ZAxisMapping" "4 5"
(**) Mouse0: ZAxisMapping: buttons 4 and 5
(**) Mouse0: Buttons: 9
(II) XINPUT: Adding extended input device "Mouse0" (type: MOUSE)
(II) XINPUT: Adding extended input device "Keyboard0" (type: KEYBOARD)
(--) Mouse0: PnP-detected protocol: "ExplorerPS/2"
(II) Mouse0: ps2EnableDataReporting: succeeded

Backtrace:
0: X(xf86SigHandler+0x81) [0x80d9511]
1: [0x98a420]
2: X [0x80a251d]
3: X(compCreateWindow+0x42) [0x819e4a2]
4: X(InitRootWindow+0x29) [0x8074339]
5: X(main+0x42f) [0x806fa0f]
6: /lib/libc.so.6(__libc_start_main+0xdc) [0x14cf2c]
7: X(FontFileCompleteXLFD+0x1e9) [0x806eda1]

Fatal server error:
Caught signal 11.  Server aborting

(II) AIGLX: Suspending AIGLX clients for VT switch
(WW) I810(0): Successfully set original devices
(WW) I810(0): Setting the original video mode instead of restoring
        the saved state
(--) I810(0): A non-CRT device is attached to pipe A.
        No refresh rate overrides will be attempted.
(WW) I810(0): Extended BIOS function 0x5f05 not supported.
(II) I810(0): BIOS call 0x5f05 not supported, setting refresh with VBE 3 method.
(II) I810(0): xf86UnbindGARTMemory: unbind key 8
(II) I810(0): xf86UnbindGARTMemory: unbind key 0
(II) I810(0): xf86UnbindGARTMemory: unbind key 1
(II) I810(0): xf86UnbindGARTMemory: unbind key 3
(II) I810(0): xf86UnbindGARTMemory: unbind key 2
(II) I810(0): xf86UnbindGARTMemory: unbind key 4
(II) I810(0): xf86UnbindGARTMemory: unbind key 5
(II) I810(0): xf86UnbindGARTMemory: unbind key 6
(II) I810(0): xf86UnbindGARTMemory: unbind key 7
(WW) I810(0): Successfully set original devices (2)
(WW) xf86CloseConsole: KDSETMODE failed: Inappropriate ioctl for device
(WW) xf86CloseConsole: VT_GETMODE failed: Inappropriate ioctl for device
(WW) xf86CloseConsole: VT_ACTIVATE failed: Inappropriate ioctl for device


Problem appeared after updateing the following xorg packages.

Mar 02 14:59:42 Updated: xorg-x11-xinit.i386 1.0.2-15.fc6
Mar 02 15:15:23 Updated: xorg-x11-server-Xnest.i386 1.1.1-47.6.fc6
Mar 02 15:16:42 Updated: xorg-x11-server-Xorg.i386 1.1.1-47.6.fc6
Mar 02 15:16:52 Updated: xorg-x11-drv-mouse.i386 1.2.1-1.fc6
Mar 02 15:16:52 Updated: xorg-x11-drv-i810.i386 1.6.5-10.fc6
Mar 02 15:17:06 Updated: xorg-x11-drv-mga.i386 1.4.5-2.fc6
Mar 02 15:17:06 Updated: xorg-x11-drv-tdfx.i386 1.3.0-2.fc6
Mar 02 15:17:06 Updated: xorg-x11-drv-trident.i386 1.2.3-1.fc6
Mar 02 15:17:06 Updated: xorg-x11-drv-s3.i386 0.5.0-1.fc6
Mar 02 15:17:07 Updated: xorg-x11-drv-ati.i386 6.6.3-1.fc6

Downgraded to the following packages and xorg started just fine.

Mar 02 16:20:45 Installed: xorg-x11-xinit.i386 1.0.2-12.fc6
Mar 02 16:24:08 Installed: xorg-x11-server-Xorg.i386 1.1.1-47.fc6
Mar 02 16:24:09 Installed: xorg-x11-drv-i810.i386 1.6.5-9.fc6
Mar 02 16:24:09 Installed: xorg-x11-drv-ati.i386 6.6.2-4.fc6
Mar 02 16:24:09 Installed: xorg-x11-drv-mga.i386 1.4.2-1.fc6
Mar 02 16:24:09 Installed: xorg-x11-drv-tdfx.i386 1.2.1-3.1
Mar 02 16:24:09 Installed: xorg-x11-drv-mouse.i386 1.1.1-1.1
Mar 02 16:24:10 Installed: xorg-x11-drv-s3.i386 0.4.1-2.1
Mar 02 16:24:10 Installed: xorg-x11-drv-trident.i386 1.2.1-3.fc6


running i810 driver

xorg hangs at blank screen if restarted.

Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1. Update xorg packages
2. startx 
3. fail/hang

Actual Results:


Expected Results:


Additional info:
Comment 1 Zachary Whitley 2007-03-02 16:59:39 EST
Updated the packages one at a time and restarted X after each package.

xorg-x11-server-Xorg.i386 1.1.1-47.6.fc6 is causing the problems.

Looking at the logs it appeared like the problem might have been with the mouse
driver so I updated that one first and X started without any problems. I then
updated xorg-x11-server-Xorg and had problems restarting. Backed out
xorg-x11-server-Xorg and it works fine.
Comment 2 Adam Jackson 2007-03-07 11:10:00 EST
Does the crash still occur if you disable the Composite extension?  Do this by
adding:

Section "Extensions"
    Option "Composite" "off"
EndSection

to the end of xorg.conf
Comment 3 Zachary Whitley 2007-03-07 12:30:14 EST
It still crashes with the Composite extension disabled.

some additional info:

lspci -v

--snip--
00:02.0 VGA compatible controller: Intel Corporation 82945G/GZ Integrated
Graphics Controller (rev 02) (prog-if 00 [VGA])
        Subsystem: Dell Unknown device 01ad
        Flags: bus master, fast devsel, latency 0, IRQ 16
        Memory at feb00000 (32-bit, non-prefetchable) [size=512K]
        I/O ports at e898 [size=8]
        Memory at e0000000 (32-bit, prefetchable) [size=256M]
        Memory at feac0000 (32-bit, non-prefetchable) [size=256K]
        Capabilities: [90] Message Signalled Interrupts: 64bit- Queue=0/0 Enable-
        Capabilities: [d0] Power Management version 2
--snip--

I'm also using 915resolution to set the vbios as follows VBMODES[1]="5c 1920
1200 32"

Comment 4 Matěj Cepl 2007-03-08 11:19:43 EST
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 5 Zachary Whitley 2007-04-04 12:07:22 EDT
Went to test and the problem seems to be resolved with xorg-X11-server-Xorg-1.1.47-7

Note You need to log in before you can comment on or make changes to this bug.