This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 230804 - nVidia MCP55 loses PCM device ALC883 - GA-M59SLI-S5
nVidia MCP55 loses PCM device ALC883 - GA-M59SLI-S5
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-02 18:17 EST by Gerald Cox
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-18 10:41:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
SCSCONFIG.LOG (75.73 KB, text/plain)
2007-03-31 17:42 EDT, Gerald Cox
no flags Details
scsconfig.log (48.72 KB, text/plain)
2007-09-08 13:52 EDT, ym
no flags Details

  None (edit)
Description Gerald Cox 2007-03-02 18:17:42 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2

Description of problem:
Building new system using Gigabyte GA-M59SLI-S5 motherboard.  During clean install of FC6 (kernel-2.6.18-1.2798) soundcard was detected as 
nVidia Corporation MCP55 High Definition Audio
PCM device:  ALC833 Analog
Sound played correctly.  
When rebooting under kernel-2.6.18-1.2798 PCM device of ALC883 Analog disappears. Reboot several times, each time going thru GNOME dialog to reload sound drivers and about 1 time out of 10 sound comes back, but disappears after next reboot.  Upgraded to kernel-2.6.19-1.2911 - same symptoms.

Version-Release number of selected component (if applicable):
kernel-2.6.19-1.2911

How reproducible:
Always


Steps to Reproduce:
1.  Reload audio drivers in GNOME dialog
2.  Reboot system


Actual Results:
ALC883 drivers not found.  Sound does not function.

Expected Results:
ALC883 drivers associated with nVidia MCP55
Sound works normally

Additional info:
Comment 1 Chuck Ebbert 2007-03-30 18:13:52 EDT
A test kernel is at http://people.redhat.com/cebbert

This may fix the problem. Please test.
Comment 2 Gerald Cox 2007-03-31 12:32:04 EDT
Thank you.  I have updated to kernel-2.6.20-1.2938.fc6 and am still having the
same issue.  When I go into sound card detection, I see the card as:
Vendor:  nVidia
Model:  Corporation MCP55 High Definition Audio
Module:  snd-hda-intel

However, no device is shown under Device Settings, PCM device.  For it to work
it should show ALC883, and it doesn't.  Let me know of any other information I
can give to assist in problem determination.  Please let me know the specific
commands.  Thanks again for your assistance.
Comment 3 Gerald Cox 2007-03-31 17:42:48 EDT
Created attachment 151366 [details]
SCSCONFIG.LOG
Comment 4 Gerald Cox 2007-04-12 00:42:00 EDT
Exact problem also occurs in FC7 TEST 3.
Comment 5 Jack Deslippe 2007-06-10 23:33:14 EDT
I also have this exact same problem on FC7 final release.  I also have the
GA-M59SLI-S5 motherboard.  It makes me very sad!!  I also have to boot with the
noapic option - could this be causing the problem with sound?    
Comment 6 Gerald Cox 2007-07-04 09:29:35 EDT
Changing to S7
Comment 7 Gerald Cox 2007-07-04 19:08:58 EDT
Found a reference to option "pci=noacpi" tried and it appears to work much
better than using the "noapic" option.  The "noapic" option was causing problems
with my soundcard and tvtuner card.  I've only been running this way for six
hours but so far so good.  Your mileage may vary.  It appears the problem with
the motherboard is related to "acpi" and NOT "apic".  To make the change either
go into root mode or use sudo, then edit /boot/grub/grub.conf
go to the line which begins with "kernel", and add "pci=noacpi" (without quotes). 
My entries now appear as follows:

title Fedora (2.6.21-1.3228.fc7)
        root (hd0,0)
        kernel /vmlinuz-2.6.21-1.3228.fc7 ro root=LABEL=/ pci=noacpi rhgb quiet
        initrd /initrd-2.6.21-1.3228.fc7.img
title Fedora (2.6.21-1.3194.fc7)
        root (hd0,0)
        kernel /vmlinuz-2.6.21-1.3194.fc7 ro root=LABEL=/ pci=noacpi rhgb quiet
        initrd /initrd-2.6.21-1.3194.fc7.img
Comment 8 Lacrocivious Acrophosist 2007-07-26 20:35:22 EDT
I have the same problem, though perhaps less severe (sound loss at 7 of 10
boots), with the Asus M2N-E mainboard and FC6, from the day the system was built
(kernel-2.6.18-1.2798.fc6 or earlier).

I had some luck, maybe, with the "pci=nomsi" option, but just as with the noacpi
and noapci options, the results weren't conclusive or reliably reproducible and
eventually through kernel updates I stopped using any options aside from
"selinux=0" and "vga=791". 

Power cycles have a higher percentage of successful sound initialization than do
hardware resets or warm boots. If I had to guess I'd say this smells like a
timing issue at initialization.

On a few occasions sound has disappeared *during* a session, with any attempt to
play music, etc., popping up a failure dialog with "audio is busy" or words to
that effect. The "Generate sound log file /root/scsconfig.log" hasn't been of
any help to me, but I'm not a programmer.

The system is fairly vanilla. I've also had various non-reproducible flakiness
with the onboard ethernet -- can "forcedeth.c" be a *good* thing? -- and have
with colleagues developed a hypothesis that the nVidia MCP-5xx chipsets may not
yet be fully cooked.


Comment 9 Jack Deslippe 2007-08-28 16:18:33 EDT
Gerald, I still use the noapic option but this soundcard issue seems to have
gone away for me in one of the kernel updates.  Perhaps I will try your
pci=nacpi for kicks tonight just to see if it does anything different.  
Comment 10 Gerald Cox 2007-08-28 16:56:11 EDT
I have been running with the "pci=noacpi" option for several months now with
good results.  I just upgraded to kernel 2.6.22.4-65.fc7 and unfortunately, the
system won't boot without it.  I'm not sure exactly the reason behind this...
I'm just glad I have found an acceptable work around. 
Comment 11 Jack Deslippe 2007-08-28 17:01:19 EDT
I think I have the same board as you (from your other bug report).  I have been
booting with "noapic" - if I remove it, it doesn't boot because of the timer
error.  Is there any reason why "pci=noacpi" is a better choice than "noapic" -
I admit that I don't really no what either of these mean.
Comment 12 Gerald Cox 2007-08-28 19:40:36 EDT
I would defer to the developers - not sure what is causing the issue.  I posted
the circumvention here to assist others who were having the same issue.  Appears
to be AMD AM2 related.  Google:  APIC AM2 LINUX
Comment 13 ym 2007-09-08 13:52:40 EDT
Created attachment 190811 [details]
scsconfig.log
Comment 14 ym 2007-09-08 13:56:03 EDT
Hi people,
I just did a FC7 install (Kernel 2.6.22.4-65.fc7) on my asus M2N-E AM2 mobo, 
with ALSA driver 1.0.14, Lib alsa-lib-1.0.14-3.fc7, util 
alsa-utils-1.0.14-1.fc7.

The audio card detected was nvidia MCP55 High Definition Autdio, PCM AD198x 
Digital.  I get no sound from either digital or analog audio options.  

I also have a windows XP sp2 dual boot on the same configuration, and that 
same output worked properly (not a hardware issue).  I also have a spare sound 
blaster live! sound card, and when plugged in, ALSA detected it properly and 
everything worked also.  

Attached is my scsconfig.log file generated from my 'audio configuration'

Thanks!
Comment 15 Gerald Cox 2007-09-13 23:43:02 EDT
I did some additional searches and found that "acpi_use_timer_override" also
fixes the problem and apparently for this particular motherboard is the
workaround of choice and the only option needed.  Looks like the problem is because 
HPET (high precision event timer) support isn't correctly implemented in the BIOS.  

I also found where there is some work going on in to enable HPET support for
motherboards with a broken bios:
http://lkml.org/lkml/2007/4/20/374

Why so many different manufacturers have the same problem is curious - and looks
like it might point back to NVIDIA.  

In the meantime, in addition to changing to the above option, I've opened a bug
report with Gigabyte asking them to enable HPET support.  Looks like they have
already fixed on the GA-M57SLI-S4 BIOS.
Comment 16 Gerald Cox 2007-09-17 19:14:36 EDT
Gigabyte has provided a test BIOS "m59slis5.f8g" which appears to have fixed the
problem.  They should be posting on their website; or you can request it
directly from them via their website.  I am now able to boot without using the
"acpi_user_timer_override" parameter.  
Comment 17 ym 2007-09-24 21:15:33 EDT
unfortunately for me, the Asus M2N-E board with the new bios (2007 Jul 09) did
not fix the problem.  Again, my windows partition will use both the mobo spdif
and the soundblaster spdif, but on fedora 7 only the soundblaster one works.

Y.
Comment 18 Gerald Cox 2007-09-24 21:50:10 EDT
Did the bios you installed have HPET support.  If so, did you enable...it might
not have come enabled.  If that doesn't work, did you try the
"acip_user_time_override" parameter when booting?  If none of that works then
looks like you have another problem and should open a new bug report.  This bug
report is specific to the Gigabyte GA-M59SLI-S5 motherboard.  

Note You need to log in before you can comment on or make changes to this bug.