Bug 230911 - SATA_NV: ADMA, ATA2 hangs, freezes system and does a soft reset
SATA_NV: ADMA, ATA2 hangs, freezes system and does a soft reset
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-04 12:40 EST by Guido Ledermann
Modified: 2013-07-02 22:32 EDT (History)
3 users (show)

See Also:
Fixed In Version: 2.6.20-1.3023.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-28 22:35:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of dmesg (38.72 KB, application/octet-stream)
2007-03-07 17:42 EST, Guido Ledermann
no flags Details
Output of lscpi -vvv (19.12 KB, application/octet-stream)
2007-03-07 17:43 EST, Guido Ledermann
no flags Details

  None (edit)
Description Guido Ledermann 2007-03-04 12:40:46 EST
Description of problem:
Using Kernel 2.6.20-1.2962.fc7 but has the same problem with 2960. It does not
appear with 2911 under FC6.

Version-Release number of selected component (if applicable):
2.6.20-1.2960.fc7
2.6.20-1.2962.fc7

How reproducible:
I don't know because I haven't really found out when it excactly happens. I
think it happens occassionally under load.

Steps to Reproduce:
1. ?
  
Additional info:
Mar  4 18:16:55 helios kernel: ata2: EH in ADMA mode, notifier 0x0
notifier_error 0x0 gen_ctl 0x1501000 status 0x500 next cpb count 0x0 next cpb
idx 0x0
Mar  4 18:16:55 helios kernel: ata2: CPB 3: ctl_flags 0x1f, resp_flags 0x1
Mar  4 18:16:55 helios kernel: ata2.00: exception Emask 0x0 SAct 0x8 SErr 0x0
action 0x2 frozen
Mar  4 18:16:55 helios kernel: ata2.00: cmd 61/08:18:39:53:76/00:00:2a:00:00/40
tag 3 cdb 0x0 data 4096 out
Mar  4 18:16:55 helios kernel:          res 40/00:00:00:00:00/00:00:00:00:00/00
Emask 0x4 (timeout)
Mar  4 18:16:55 helios kernel: ata2: soft resetting port
Mar  4 18:16:55 helios kernel: ata2: SATA link up 3.0 Gbps (SStatus 123 SControl
300)
Mar  4 18:16:55 helios kernel: ata2.00: configured for UDMA/133
Mar  4 18:16:55 helios kernel: ata2: EH complete
Mar  4 18:16:55 helios kernel: SCSI device sda: 781422768 512-byte hdwr sectors
(400088 MB)
Mar  4 18:16:55 helios kernel: sda: Write Protect is off
Mar  4 18:16:55 helios kernel: SCSI device sda: write cache: enabled, read
cache: enabled, doesn't support DPO or FUA
Comment 1 Alan Cox 2007-03-07 14:34:55 EST
Please attach an lspci -vxx so I can see what hardware you have and if possible
a dmesg from the boot.
Comment 2 Guido Ledermann 2007-03-07 17:42:41 EST
Created attachment 149518 [details]
Output of dmesg
Comment 3 Guido Ledermann 2007-03-07 17:43:56 EST
Created attachment 149519 [details]
Output of lscpi -vvv

HTH. Guido
Comment 4 Alan Cox 2007-03-08 07:57:13 EST
Thanks this identifies the device concerned, and I've reassigned it to Jeff the
SATA maintainer. It looks like several reports of problems with ADMA mode that
are being worked on currently upstream.
Comment 5 Guido Ledermann 2007-03-25 04:56:36 EDT
I think this can be closed. It works fine for me with the latest kernels.

Note You need to log in before you can comment on or make changes to this bug.