Bug 230912 - Firewire drive not unmounted properly during shutdown
Firewire drive not unmounted properly during shutdown
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
6
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-04 12:44 EST by Michael Mol
Modified: 2014-03-16 23:06 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-06 16:29:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Mol 2007-03-04 12:44:03 EST
Description of problem:

When computer is rebooted, ext3 partition on external IEEE1394 drive is flagged
as unclean, and fsck checks the drive.  fsck reports that manual fsck is
necessary.  Manual fsck detects thousands of errors, totalling 14GB of bad
inodes and directories. (7GB first time, 7.4GB second time)  External drive is
mounted as my /home partition, so this is particularly painful.

How reproducible:

Every time I reboot. (Twice now.)


Steps to Reproduce:
1. Shutdown through System->Shutdown
2. Power on machine
3. !Profit
  
Actual results:

System checks /dev/sda1 for errors, finds them, requires manual fsck.

"fsck -vy /dev/sda1" returns thousands of errors in most stages of the fsck process.

Expected results:

I would expect a clean bootup without hemorraging data.


Additional info:

Firewire drive is a 250GB hard drive in an external enclosure, connected to
Firewire PCI expansion card.

lspci output:

shortcircuit@caterpillar.wonderland~
12:28:17 $ /sbin/lspci
00:00.0 Host bridge: Intel Corporation 82845G/GL[Brookdale-G]/GE/PE DRAM
Controller/Host-Hub Interface (rev 01)
00:02.0 VGA compatible controller: Intel Corporation 82845G/GL[Brookdale-G]/GE
Chipset Integrated Graphics Device (rev 01)
00:1d.0 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M)
USB UHCI Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M)
USB UHCI Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M)
USB UHCI Controller #3 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801DB/DBM (ICH4/ICH4-M) USB2 EHCI
Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 81)
00:1f.0 ISA bridge: Intel Corporation 82801DB/DBL (ICH4/ICH4-L) LPC Interface
Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801DB (ICH4) IDE Controller (rev 01)
00:1f.3 SMBus: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) SMBus
Controller (rev 01)
01:08.0 Ethernet controller: Intel Corporation 82801DB PRO/100 VE (CNR) Ethernet
Controller (rev 81)
01:0c.0 PCI bridge: Pericom Semiconductor PCI to PCI Bridge (rev 01)
01:0d.0 Ethernet controller: Accton Technology Corporation SMC2-1211TX (rev 10)
02:05.0 Ethernet controller: Atheros Communications, Inc. AR5005G 802.11abg NIC
(rev 01)
02:06.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host Controller
(rev 46)
02:07.0 USB Controller: NEC Corporation USB (rev 41)
02:07.1 USB Controller: NEC Corporation USB (rev 41)
02:07.2 USB Controller: NEC Corporation USB 2.0 (rev 02)
02:08.0 Multimedia controller: Philips Semiconductors SAA7133/SAA7135 Video
Broadcast Decoder (rev d1)
02:0a.0 Multimedia audio controller: Ensoniq ES1371 [AudioPCI-97] (rev 06)
shortcircuit@caterpillar.wonderland~
12:28:22 $ 

Contents of /etc/fstab:
shortcircuit@caterpillar.wonderland~
12:28:22 $ cat /etc/fstab
LABEL=/                 /                       ext3    defaults        1 1
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
tmpfs                   /dev/shm                tmpfs   defaults        0 0
LABEL=/home             /home                   ext3    defaults        1 2
proc                    /proc                   proc    defaults        0 0
sysfs                   /sys                    sysfs   defaults        0 0
LABEL=SWAP-sdb1         swap                    swap    defaults        0 0
shortcircuit@caterpillar.wonderland~
12:29:52 $ 

Output of mount:
shortcircuit@caterpillar.wonderland~
12:29:52 $ mount
/dev/hda1 on / type ext3 (rw)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
tmpfs on /dev/shm type tmpfs (rw)
/dev/sda1 on /home type ext3 (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
shortcircuit@caterpillar.wonderland~
12:30:23 $
Comment 1 Michael Mol 2007-03-06 16:28:46 EST
I'm sorry.  The problem wasn't what I thought it was.  Turns out, my Firewire
card went flaky the same day as I installed Fedora.  Switching the drive to
connect through USB fixed the problem.

Note You need to log in before you can comment on or make changes to this bug.