Bug 23092 - getting a segmentation fault while compiling SimGear
getting a segmentation fault while compiling SimGear
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.0
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-01 12:31 EST by Eric White
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-03 22:39:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the file you requested previously (sorry) (239.79 KB, text/plain)
2001-01-03 22:39 EST, Eric White
no flags Details

  None (edit)
Description Eric White 2001-01-01 12:31:33 EST
I'm trying to build SimGear-0.0.14 on a RH7.0 system with:

Reading specs from /usr/lib/gcc-lib/i386-redhat-linux/2.96/specs
gcc version 2.96 20000731 (Red Hat Linux 7.0)

My ./configure process seems to work fine (no errors). The make produces:

gcc -DHAVE_CONFIG_H -I. -I. -I../../simgear -I../..   -I/usr/local/include
-I/usr/X11R6/include  -g -O2 -c xmltok.c
In file included from xmltok.c:654:
xmltok_impl.c: In function `little2_checkPiTarget':
xmltok_impl.c:207: Internal error: Segmentation fault.
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[3]: *** [xmltok.o] Error 1
make[3]: Leaving directory `/usr/src/SimGear-0.0.14/simgear/xml'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/usr/src/SimGear-0.0.14/simgear'
make[1]: *** [all-recursive-am] Error 2
make[1]: Leaving directory `/usr/src/SimGear-0.0.14/simgear'
make: *** [all-recursive] Error 1
Comment 1 Jakub Jelinek 2001-01-02 02:30:10 EST
Please run
gcc -DHAVE_CONFIG_H -I. -I. -I../../simgear -I../..   -I/usr/local/include
-I/usr/X11R6/include  -g -O2 -c xmltok.c -save-temps -v
and send me xmltok.i this command creates.
Also, do you use gcc errata packages or gcc which shipped in 7.0?
Comment 2 Jakub Jelinek 2001-01-02 04:33:48 EST
Also, is this reprocible? I've just tried it on my box with both
gcc-2.96-69 (current errata) and gcc-2.96-54 and have not seen segfault
in either case.
Comment 3 Eric White 2001-01-02 22:18:55 EST
Here's the output from the gcc line you wanted:

[root@weisshaus xml]# gcc -DHAVE_CONFIG_H -I. -I. -I../../simgear -I../..  
-I/usr/local/include -I/usr/X11R6/include  -g -O2 -c xmltok.c -save-temps -v
Reading specs from /usr/lib/gcc-lib/i386-redhat-linux/2.96/specs
gcc version 2.96 20000731 (Red Hat Linux 7.0)
 /usr/lib/gcc-lib/i386-redhat-linux/2.96/cpp0 -lang-c -v -I. -I. -I../../simgear
-I../.. -I/usr/local/include -I/usr/X11R6/include -D__GNUC__=2
-D__GNUC_MINOR__=96 -D__GNUC_PATCHLEVEL__=0 -D__ELF__ -Dunix -Dlinux -D__ELF__
-D__unix__ -D__linux__ -D__unix -D__linux -Asystem(posix) -D__OPTIMIZE__ -g
-Acpu(i386) -Amachine(i386) -Di386 -D__i386 -D__i386__ -D__tune_i386__
-DHAVE_CONFIG_H xmltok.c xmltok.i
GNU CPP version 2.96 20000731 (Red Hat Linux 7.0) (cpplib)
 (i386 Linux/ELF)
ignoring nonexistent directory "/usr/i386-redhat-linux/include"
ignoring duplicate directory "."
ignoring duplicate directory "/usr/local/include"
#include "..." search starts here:
#include <...> search starts here:
 .
 ../../simgear
 ../..
 /usr/local/include
 /usr/X11R6/include
 /usr/lib/gcc-lib/i386-redhat-linux/2.96/include
 /usr/include
End of search list.
 /usr/lib/gcc-lib/i386-redhat-linux/2.96/cc1 xmltok.i -quiet -dumpbase xmltok.c
-g -O2 -version -o xmltok.s
GNU C version 2.96 20000731 (Red Hat Linux 7.0) (i386-redhat-linux) compiled by
GNU C version 2.96 20000731 (Red Hat Linux 7.0).
In file included from xmltok.c:654:
xmltok_impl.c: In function `little2_checkPiTarget':
xmltok_impl.c:207: Internal error: Segmentation fault.
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.

to answer your questions:

1) It's endlessly reproducible
2) I received RH7.0 last week, upgraded an RH6.2 system, used the RH7.0 errata
CD to update my new 7.0 system, then used RH Update Agent to update several
things including the libc library and gcc (is there a log file for the Update
Agent, so I could send you the list of updated items?)
Comment 4 Jakub Jelinek 2001-01-03 02:57:33 EST
You have not attached xmltok.i, can you please attach it to this
report or mail it to me directly? Thanks.
Comment 5 Eric White 2001-01-03 22:39:17 EST
Created attachment 7023 [details]
the file you requested previously (sorry)
Comment 6 Jakub Jelinek 2001-01-04 08:11:44 EST
Cannot reproduce this (I've tried all gcc rpms since June (well, I have them
all unpacked) and none of them segfaults on this).
I'd suspect bad memory or something like that...

Note You need to log in before you can comment on or make changes to this bug.