Bug 230972 - Qdisk daemon unable to be started on all members in Xen cluster setup
Qdisk daemon unable to be started on all members in Xen cluster setup
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cman (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lon Hohberger
Cluster QE
:
: 230971 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-05 03:04 EST by Dean Samuels
Modified: 2010-10-22 09:30 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2007-0575
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 11:59:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
update patch for RHEL5.0 qdisk -> RHEL5 stable development (51.12 KB, patch)
2007-03-06 10:52 EST, Lon Hohberger
no flags Details | Diff

  None (edit)
Description Dean Samuels 2007-03-05 03:04:09 EST
Description of problem:
Starting qdisk service fails on all Xen domU cluster members (2-node cluster). 
cluster.conf configuration as follows:
<quorumd device="/dev/sdb" interval="1" label="quorum" min_score="3" tko
="10" votes="3">
                <heuristic interval="2" program="ping b -c1 -t1" score="1"/>
</quorumd>

Version-Release number of selected component (if applicable):
cman-2.0.60-1.el5

How reproducible:
Configure qurourm device via system-config-cluster.  Create quorum disk seen by
all members via mkqdisk command.  Attempt to start qdiskd daemon fails.


Steps to Reproduce:
1.  Create cluster with quorum device via system-config-cluster
2.  Add in apprppriate heuristics
3.  Start cman services - successful
4.  Start qdiskd service -fails with errror 
"Could not determine local node ID; cannot start"
  
Actual results:
Qdiskd fails to start so quorum device cannot be used as part of cluster.


Expected results:
Qdiskd starts successfully and quorum device part of cluster, seen via clustat
command.  Optional status file also updated as specified in cluster.conf.

Additional info:
Comment 1 Christine Caulfield 2007-03-05 04:18:47 EST
*** Bug 230971 has been marked as a duplicate of this bug. ***
Comment 2 Lon Hohberger 2007-03-05 10:56:40 EST
This is fixed in 4.5/5.1, or should be.   It may warrant an errata against 5.0.
Comment 3 Dean Samuels 2007-03-05 16:03:03 EST
Can the updated packages be made available so I may test?  I'm assuming it's an
update to the cman package?
Comment 4 Lon Hohberger 2007-03-06 09:53:22 EST
I have some cman & cman-kernel packages with just qdisk-required updates for
42.0.3 & 42.0.8 RHEL4 errata kernels here:

http://people.redhat.com/lhh/packages.html
Comment 5 Lon Hohberger 2007-03-06 10:02:03 EST
Oh - I missed that this is RHEL5.  I'll build something shortly.
Comment 6 Lon Hohberger 2007-03-06 10:52:12 EST
Created attachment 149344 [details]
update patch for RHEL5.0 qdisk -> RHEL5 stable development
Comment 7 Robert Hell 2007-03-30 05:17:33 EDT
Hi! I got the same Problem with RHEL5. Will there be an errata or how can i get 
a supported fix?
Comment 8 Edouard Bourguignon 2007-04-20 04:57:30 EDT
same problem on FC6
Comment 9 Kiersten (Kerri) Anderson 2007-04-23 12:49:44 EDT
Fixing Product Name.  Cluster Suite was merged into Red Hat Enterpise Linux for
5.0.  In addition dlm, fence and ccs were merged into the cman package, so
bugzilla should reflect package name where those utilities are located.
Comment 11 RHEL Product and Program Management 2007-05-07 15:06:03 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 12 Robert Hell 2007-05-29 09:08:06 EDT
Any news if there will be an official errata for this problem?
Comment 16 Lon Hohberger 2007-08-27 12:24:24 EDT
This is fixed in 5.1 beta - give it a spin?
Comment 20 errata-xmlrpc 2007-11-07 11:59:10 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0575.html

Note You need to log in before you can comment on or make changes to this bug.