Bug 231006 - ATI Radeon Mobility X1600 can't load xorg
ATI Radeon Mobility X1600 can't load xorg
Status: CLOSED DUPLICATE of bug 241491
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-vesa (Show other bugs)
7
All Linux
medium Severity high
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks: 235422
  Show dependency treegraph
 
Reported: 2007-03-05 10:06 EST by Russell Harrison
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-14 12:12:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda.xlog (87.99 KB, text/plain)
2007-03-07 17:12 EST, Russell Harrison
no flags Details
Xorg log from system-config-display (897 bytes, text/plain)
2007-03-07 17:13 EST, Russell Harrison
no flags Details
temporary X config used by system-config-display (801 bytes, text/plain)
2007-03-07 17:13 EST, Russell Harrison
no flags Details
FC6 Xorg.0.log (92.56 KB, application/octet-stream)
2007-03-08 16:10 EST, Russell Harrison
no flags Details
anaconda.xlog from FC6 (92.18 KB, text/plain)
2007-03-08 16:12 EST, Russell Harrison
no flags Details
rawhide anaconda.xlog (88.32 KB, text/plain)
2007-03-16 17:29 EDT, Russell Harrison
no flags Details
rawhide anaconda.syslog (44.36 KB, text/plain)
2007-03-16 17:31 EDT, Russell Harrison
no flags Details

  None (edit)
Description Russell Harrison 2007-03-05 10:06:32 EST
I'm attempting to test Fedora 7 Test 2 on a HP Compaq nw8440 and the install is
unable to load the vesa (or any other) drivers to do a graphical install.  Its
also unable to load any drivers for firstboot causing it to fail.

I'm sure the ATI drivers would work once they are fixed but that still leaves
the problem of graphical installs, and firstboot.  Besides the fact that untill
the ATI drivers are fixed there isn't any graphical solution for this card.

Running lspci on the nw8440 shows the following video card.

01:00.0 VGA compatible controller: ATI Technologies Inc M56P [Radeon Mobility X1600]

The vesa drivers did work for FC6, RHEL 5b2, and F7t1, but do not work on the
latest packages from rawhide.

xorg-x11-drv-vesa-1.3.0-4.fc7
Comment 1 Adam Jackson 2007-03-07 10:59:55 EST
Why does the vesa driver fail?  Can you attach /var/log/Xorg.0.log from a failed
startup?
Comment 2 Russell Harrison 2007-03-07 17:12:34 EST
Created attachment 149503 [details]
anaconda.xlog
Comment 3 Russell Harrison 2007-03-07 17:13:02 EST
Created attachment 149504 [details]
Xorg log from system-config-display
Comment 4 Russell Harrison 2007-03-07 17:13:37 EST
Created attachment 149505 [details]
temporary X config used by system-config-display
Comment 5 Russell Harrison 2007-03-07 17:15:57 EST
The driver fails during install when anaconda attempts to go graphical, and also
fails to start when I attempt to use system-config-display.

All of these work fine for FC6 on the same machine.  I've attached the
anaconda.xlog and the files from system-config-display.
Comment 6 Matěj Cepl 2007-03-08 11:57:30 EST
Could we get at least (when Rawhide Xorg didn't install properly)
/var/log/Xorg.0.log from FC6, to get all collected information about your
hardware, please? Thanks a lot.
Comment 7 Russell Harrison 2007-03-08 16:10:07 EST
Created attachment 149635 [details]
FC6 Xorg.0.log
Comment 8 Russell Harrison 2007-03-08 16:12:09 EST
Created attachment 149638 [details]
anaconda.xlog from FC6
Comment 9 Russell Harrison 2007-03-08 16:14:11 EST
OK I uploaded the logs from the FC6 install I did today.

Let me make a ks.cfg for this FC6 install and then I'll try and do a rawhide
kickstart from scratch, rather than a F7t2 install.  Probably sometime tomorrow.
Comment 10 Adam Jackson 2007-03-12 13:03:36 EDT
Er, this _should_ be working with 1.3.0-4, it's just not the one that's in the
test2 install image.  Does X work after install?
Comment 11 Russell Harrison 2007-03-12 17:17:03 EDT
It didn't, after the install I did a full yum update and rebooted.  Still
couldn't configure X.
Comment 12 Adam Jackson 2007-03-14 18:25:01 EDT
Does it fail differently at least?  Can you attach a log from 1.3.0-4?  The one
in comment #2 doesn't appear to be from 1.3.0-4, and I'm almost certain I fixed
that failure case.
Comment 13 Russell Harrison 2007-03-14 18:55:29 EDT
I still haven't had a chance to rekick the system.  I can confirm that its also
broken in the just released RHEL-5 however.  :-(
Comment 14 Russell Harrison 2007-03-16 17:29:41 EDT
Created attachment 150280 [details]
rawhide anaconda.xlog
Comment 15 Russell Harrison 2007-03-16 17:31:22 EDT
Created attachment 150281 [details]
rawhide anaconda.syslog
Comment 16 Russell Harrison 2007-03-16 17:35:03 EDT
OK, I finally had a chance to install from the devel tree.  I've atached the
anaconda logs.  Let me know if you need anything else.  X won't start at all so
I can't get a Xorg log for you. :-(
Comment 17 Adam Jackson 2007-04-11 13:54:14 EDT
Does xorg-x11-drv-vesa 1.3.0-5 resolve this?  It really should, there's a second
validation pass now that won't try to do strict intersection between EDID and
VBE mode lists.
Comment 18 Russell Harrison 2007-04-20 19:50:23 EDT
I'm having trouble getting the latest rawhide to install at all on the box. 
There seems to be something wrong with the ramdisk in the current rescue cds.
Comment 19 Russell Harrison 2007-04-30 12:52:03 EDT
I have confirmed that the Fedora 7 Test 4 anaconda still fails.  I assume that
it does include version 1.3.0-5 or higher of the vesa drivers?
Comment 20 Marc Wiriadisastra 2007-05-21 11:36:22 EDT
I'm having the same issue with an x1300 Dell at the moment.  Exactly the same
issue.  FC6 I can install using graphical mode fc7 test versions I can't.  Same
details during the install it switches to the vesa drivers and goes in text
mode.  Then after the install I can't load X even with vesa put in the xorg line.
Comment 21 Matěj Cepl 2007-05-26 10:54:39 EDT
Maybe related bug is bug 240591 (crash which looks like in xfs, which is
strange; but hardware and distro are same).
Comment 22 Adam Jackson 2007-05-26 14:27:01 EDT
*** Bug 240591 has been marked as a duplicate of this bug. ***
Comment 23 Marc Wiriadisastra 2007-05-30 10:27:45 EDT
Not sure if this helps.  Gentoo 2007.0 Livecd has the same issues as does Ubuntu
feisty.

Bug reports here 

https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/103945
http://bugs.gentoo.org/show_bug.cgi?id=177726

I'm hoping this can get fixed before fc7 goes public but I'm having my doubts :(
Comment 24 Russell Harrison 2007-05-31 21:27:05 EDT
I'm changing the product version over to F7 since this bug maid it to the GA
version of F7
Comment 25 Marc Wiriadisastra 2007-05-31 21:29:19 EDT
The gnome Live-cd loaded my x1300 fine.  Am I the only one that this is fixed for?
Comment 26 Matěj Cepl 2007-06-01 03:59:23 EDT
Marc, Russell -- could you give me both output of

    rpm -q xorg-x11-drv-ati

please?

Thank you
Comment 27 Marc Wiriadisastra 2007-06-01 05:04:04 EDT
[root@Strikelap log]# rpm -q xorg-x11-drv-ati
xorg-x11-drv-ati-6.6.3-2.fc7
Comment 28 Russell Harrison 2007-06-05 18:07:41 EDT
(In reply to comment #27)
> [root@Strikelap log]# rpm -q xorg-x11-drv-ati
> xorg-x11-drv-ati-6.6.3-2.fc7
> 

Thanks for jumping on that for me Marc.  That is the same version I'm seeing the
problem with.
Comment 29 Russell Harrison 2007-06-13 19:14:08 EDT
This seems to be fixed with the latest round of updates.  Now I just need to
figure out how to make a new iso so anaconda will work as well.
Comment 30 Adam Jackson 2007-06-14 12:12:13 EDT
This is a vesa bug, not a radeon bug.  And I expect it's fixed by
xorg-x11-drv-vesa 1.3.0-8.

*** This bug has been marked as a duplicate of 241491 ***

Note You need to log in before you can comment on or make changes to this bug.